[mythtv-users] MythTV Does Not See PVR-250 - Must Fix Before Wife Returns!

Drew Tomlinson drew at mykitchentable.net
Sun Apr 10 18:06:44 UTC 2011


On 4/10/2011 11:00 AM, Mark Lord wrote:
> On 11-04-10 11:48 AM, Drew Tomlinson wrote:
>>>> Thinking that maybe this has to do with the PVR-250 not being seen by
>>>> the kernel, I checked dmesg.  Yep, it's there:
>>>>
>>>> ivtv: Start initialization, version 1.4.2
>>>> ivtv0: Initializing card 0
>>>> ivtv0: Autodetected Hauppauge card (cx23416 based)
>>>> ivtv 0000:05:06.0: PCI INT A ->   Link[APC3] ->   GSI 18 (level, low) ->   IRQ 18
>>>> ivtv0: Unreasonably low latency timer, setting to 64 (was 32)
>>>> cx88/0: cx2388x v4l2 driver version 0.0.8 loaded
>>>> tveeprom 2-0050: Hauppauge model 32062, rev C182, serial# 7812141
>>>> tveeprom 2-0050: tuner model is LG TAPC H791F (idx 82, type 39)
>>>> tveeprom 2-0050: TV standards NTSC(M) (eeprom 0x08)
>>>> tveeprom 2-0050: audio processor is MSP3445 (idx 12)
>>>> tveeprom 2-0050: decoder processor is SAA7115 (idx 19)
>>>> tveeprom 2-0050: has no radio, has IR receiver, has no IR transmitter
>>>> ivtv0: Autodetected Hauppauge WinTV PVR-250
> Here's what the full "dmesg" output looks like for a working PVR-250.
> Note that different cards may have different tuners, but the overall
> group of messages should look pretty similar to this:
>
>   ivtv0: Initializing card 0
>   ivtv0: Autodetected Hauppauge card (cx23416 based)
>   ivtv 0000:05:03.0: PCI INT A ->  GSI 18 (level, low) ->  IRQ 18
>   tveeprom 1-0050: Hauppauge model 32062, rev B185, serial# 2842715
>   tveeprom 1-0050: tuner model is TCL 2002N 6A (idx 85, type 50)
>   tveeprom 1-0050: TV standards NTSC(M) (eeprom 0x08)
>   tveeprom 1-0050: audio processor is MSP3445 (idx 12)
>   tveeprom 1-0050: decoder processor is SAA7115 (idx 19)
>   tveeprom 1-0050: has no radio, has IR receiver, has no IR transmitter
>   ivtv0: Autodetected Hauppauge WinTV PVR-250
>   saa7115 1-0021: saa7115 found (1f7115d0e100000) @ 0x42 (ivtv i2c driver #0)
>   msp3400 1-0040: MSP3445G-B8 found @ 0x80 (ivtv i2c driver #0)
>   msp3400 1-0040: msp3400 supports radio, mode is autodetect and autoselect
>   tuner 1-0061: chip found @ 0xc2 (ivtv i2c driver #0)
>   tuner-simple 1-0061: creating new instance
>   tuner-simple 1-0061: type set to 50 (TCL 2002N)
>   ivtv0: Registered device video1 for encoder MPG (4096 kB)
>   ivtv0: Registered device video33 for encoder YUV (2048 kB)
>   ivtv0: Registered device vbi1 for encoder VBI (1024 kB)
>   ivtv0: Registered device video25 for encoder PCM (320 kB)
>   ivtv0: Initialized card: Hauppauge WinTV PVR-250
>
> Those "registered" messages just above are what's most important to see.
> Lacking those means your kernel is missing some driver(s).
>
> -ml

I think I'm good.  Here's mine:

ivtv0: Initializing card 0
ivtv0: Autodetected Hauppauge card (cx23416 based)
ivtv 0000:05:06.0: PCI INT A -> Link[APC3] -> GSI 18 (level, low) -> IRQ 18
ivtv0: Unreasonably low latency timer, setting to 64 (was 32)
cx88/0: cx2388x v4l2 driver version 0.0.8 loaded
tveeprom 2-0050: Hauppauge model 32062, rev C182, serial# 7812141
tveeprom 2-0050: tuner model is LG TAPC H791F (idx 82, type 39)
tveeprom 2-0050: TV standards NTSC(M) (eeprom 0x08)
tveeprom 2-0050: audio processor is MSP3445 (idx 12)
tveeprom 2-0050: decoder processor is SAA7115 (idx 19)
tveeprom 2-0050: has no radio, has IR receiver, has no IR transmitter
ivtv0: Autodetected Hauppauge WinTV PVR-250
nvidia: module license 'NVIDIA' taints kernel.
Disabling lock debugging due to kernel taint
saa7115 2-0021: saa7115 found (1f7115d0e100000) @ 0x42 (ivtv i2c driver #0)
i2c-core: driver [msp3400] using legacy suspend method
i2c-core: driver [msp3400] using legacy resume method
cx88/2: cx2388x MPEG-TS Driver Manager version 0.0.8 loaded
nvidia 0000:01:00.0: PCI INT A -> Link[APC3] -> GSI 18 (level, low) -> 
IRQ 18
nvidia 0000:01:00.0: setting latency timer to 64
vgaarb: device changed decodes: 
PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:
owns=io+mem
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  260.19.44  Sun Feb 27 
22:41:03 PST 2011
msp3400 2-0040: MSP3445G-B8 found @ 0x80 (ivtv i2c driver #0)
msp3400 2-0040: msp3400 supports radio, mode is autodetect and autoselect
ACPI: PCI Interrupt Link [APCJ] enabled at IRQ 22
Intel ICH 0000:00:04.0: PCI INT A -> Link[APCJ] -> GSI 22 (level, low) 
-> IRQ 22
Intel ICH 0000:00:04.0: setting latency timer to 64
i2c-core: driver [tuner] using legacy suspend method
i2c-core: driver [tuner] using legacy resume method
tuner 2-0061: chip found @ 0xc2 (ivtv i2c driver #0)
intel8x0_measure_ac97_clock: measured 50676 usecs (2496 samples)
intel8x0: clocking to 46777
tuner-simple 2-0061: creating new instance
tuner-simple 2-0061: type set to 39 (LG NTSC (newer TAPC series))
ivtv0: Registered device video0 for encoder MPG (4096 kB)
ivtv0: Registered device video32 for encoder YUV (2048 kB)
ivtv0: Registered device vbi0 for encoder VBI (1024 kB)
ivtv0: Registered device video24 for encoder PCM (320 kB)
ivtv0: Initialized card: Hauppauge WinTV PVR-250
ivtv: End initialization

Thanks again,

Drew

-- 
Like card tricks?

Visit The Alchemist's Warehouse to
learn card magic secrets for free!

http://alchemistswarehouse.com




More information about the mythtv-users mailing list