[mythtv-users] HD-PVR & 2.6.38 (Gentoo masochism)

Marc Tousignant myrdhn at gmail.com
Mon Apr 4 00:29:08 UTC 2011



-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of John Drescher
Sent: Sunday, April 03, 2011 3:37 PM
To: Discussion about MythTV
Subject: Re: [mythtv-users] HD-PVR & 2.6.38 (Gentoo masochism)

On Sun, Apr 3, 2011 at 1:56 PM, Derek Stark <lemongecko at gmail.com> wrote:
> Hey guys:
> I'm trying to get my HD-PVR working with 0.24_p20110329 (I tried 0318, but
> had random lockups with my HDHR's). I'm also running the gentoo 2.6.38-r1
> kernel sources. Just to make more things interesting, I also have an
MCEUSB
> on this box (but due to install locations I can't use that blaster on my
> cable box).
> I'm just wondering, as of 2.6.38, what cocktail I need to get the HD-PVR
> running--specifically the IR transmitter. The in-kernel drivers for the
> HD-PVR seem to load and see the device (I have /dev/videoX, etc) but the
> Myth wiki is really vague on whether I need the linuxtv.org driver set,
what
> needs to be patched, ad nauseum.
> Any tips would be great. If I can get this figured out, I'll try and clean
> up the wiki.

I believe you need lirc-0.9.0 to work with ir in recent kernels. If
that has not hit portage I have an ebuild in my overlay.

https://github.com/drescherjm/jmdgentoooverlay/tree/master/app-misc/lirc

John
_______________________________________________

I don’t use the HDPVR blaster, I use the one that came with my MCE remote so
I don’t have an answer but I would believe John on this one.

However I just found out, make sure your headers are not at 2.6.38 or
higher.
It will allow you to compile Myth with support for the HDPVR but the V4L
headers are gone so it won't compile with V4L support.

I have been running the same version of fixes for at least 4+ months at this
point, I'm finally updating and finding the new quirks and working around
them.

MarcT




More information about the mythtv-users mailing list