[mythtv-users] Memory leak while watching MPEG-2 recording?

aaron memoryguy at gmail.com
Sat Apr 2 14:21:42 UTC 2011

On Sat, Mar 19, 2011 at 09:50, aaron <memoryguy at gmail.com> wrote:
> Hi,


> Is there any suggestion on how I might be able to capture a meaningful
> valgrind log?

No suggestions, eh? :(

I've just upgraded to:

myth at myth:~$ mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version   : v0.25pre-1625-gbbf345c
MythTV Branch    : master
Network Protocol : 65
Library API      : 0.25.20110328-2
QT Version       : 4.5.1
Options compiled in:
 linux release use_hidesyms using_alsa using_oss using_backend
using_bindings_perl using_bindings_python using_bindings_php using_dvb
using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv
using_libxml2 using_libudf using_lirc using_mheg using_qtdbus
using_qtwebkit using_v4l using_x11 using_xrandr using_xv
using_bindings_perl using_bindings_python using_bindings_php
using_mythtranscode using_opengl using_ffmpeg_threads using_live
using_mheg using_libxml2 using_libudf

and I still see the previously-mentioned (very fast) leak during
playback. Interestingly, I have found that the leak only seems to
affect "more recent" (not sure of when exactly it started) recordings.
Again, all of my recordings have been made with the same PVR-250, and
I have not upgraded anything other than MythTV.

I'll try valgrind again with the options that have been suggested to
others, but the memory usage is crazy and my poor system just can't
handle it...


More information about the mythtv-users mailing list