[mythtv-users] TiVo Slide Remote, Linux and Scan Codes

Jarod Wilson jarod at wilsonet.com
Mon Sep 6 04:00:25 UTC 2010

On Sun, Sep 5, 2010 at 4:10 PM, Jarod Wilson <jarod at wilsonet.com> wrote:
> On Fri, Sep 3, 2010 at 4:51 PM, Wayne Thomas <waynethomas69 at gmail.com> wrote:
>>>> 0000030 005c ffbc 0001 0000 005c ffbc 0000 0000
>>>> ...for each press of a key that currently doesn't work.  From the
>>>> example above (Green button on the Emprex) the usage page appears
>>>> twice (ffbc) as does the output for that key (005c).  If the usage
>>>> page is also ffbc you are in luck and should be able to add all of the
>>>> keys to the topseed driver (assuming they aren't already covered).
>>> hexdump /dev/usb/hiddev0
>>> 0000000 0000 000c 0000 0000 0041 000c 0001 0000
>>> 0000010 0041 000c 0000 0000 0000 000c 0001 0000
>>> 0000020 0020 000c 0053 0000
>>> hexdump -e '1/1 "%2.2x" "\n"' /dev/usb/hiddev0
>>> 00*0c00*41000c000100*41000c00*0c000100*20000c005300*
>>> This is for the "Select" key (0x41). Unfortunately, I'm not seeing any
>>> instances of 0xffbc. I'm skeptical of 0x000c being its usage page --
>>> each device type should have a unique one, correct?
>>> Thanks,
>>> Joe
>> 000c is defined as the consumer usage page (HID_UP_CONSUMER), I just
>> checked hid-input.c and 0x41 isn't defined as an output on that page.
>> This will need to be added like...
>> case 0x041: map_key_clear(KEY_SELECT);            break;
>> to hid-input.c and that key will magically work.
>> My remote had a combination of keys on the two usage pages (ffbc and
>> 000c).  So that key is no great surprise, I would be interested to see
>> the output of the other keys that aren't working.
> They're all either HID_UP_CONSUMER or HID_UP_KEYBOARD. It looks like
> all the changes necessary to fully support all the keys on this thing
> will be within hid-input.c. I'm doing a test build right now w/an
> updated hid-input.c to see if I don't have 'em all working now. :)
> (picked the remote up an hour or two ago. :)

Had a bbq to go to, then had to fight with the stupid thing a bit to
get it to re-pair. Now that that's out of the way, I can report that
all but three keys (Live TV, thumbs up and thumbs down) are working
properly. Looking into those next. They currently show up in evtest as
EV_ABS type events, identically, like so:

Event: time 1283745547.651536, type 3 (Absolute), code 40 (Misc), value 0
Event: time 1283745547.651579, -------------- Report Sync ------------
Event: time 1283745547.856519, type 3 (Absolute), code 40 (Misc), value 1
Event: time 1283745547.856543, -------------- Report Sync ------------

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list