[mythtv-users] mythtv and judder free playback

Phil Wild philwild at gmail.com
Wed Oct 27 13:49:58 UTC 2010

On 26 October 2010 09:39, Jean-Yves Avenard <jyavenard at gmail.com> wrote:
> Hi
> On 26 October 2010 03:34, John Drescher <drescherjm at gmail.com> wrote:
>> I believe the part of problem is nvidia drivers do not (by default)
>> report the correct frequency in xrandr.
>> For me I believe 50 Hz is reported and that really means 85 Hz on my
>> CRT monitor.
> This is irrelevant for MythTV ; those are "TwinView" xrandr values,
> and mythtv supports those and will properly retrieve the correct
> value.
> e.g. it "knows" that the 50Hz entry is in fact 85Hz.
> The issue is that xorg.conf was set with a list of refresh rate that
> the TV doesn't support. Either you don't touch xorg.conf at all and
> only rely on the values provided by the TV, or you manually configure
> the refresh rates in xorg.conf , but only put there the ones you know
> your TV supports.

Below is my xorg.conf file and xrandr reports the following (1920x1080
line only)
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      50.0     51.0     52.0*    53.0     54.0     55.0
 56.0     57.0     58.0     59.0

using xrandr -r X I have worked through 50 through 59 and 53 is the
only entry that does not work. when running xrandr -r 53, the
following entry ends up in the xorg log file
NVIDIA(0): Setting mode "1920x1080_60_1"

This entry does not exist in my xorg.conf file.

What am I doing wrong?

===star xorg.conft===

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "ServerFlags"
    Option         "Xinerama" "0"

Section "InputDevice"

    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SAMSUNG"
    HorizSync       20.0 - 150.0
    VertRefresh     23.0 - 90.0
        # 1920x1080p @ 50Hz (EIA/CEA-861B)
        # 1920x1080p @ 60Hz (EIA/CEA-861B)
        # 1920x1080p @ 24Hz (EIA/CEA-861B)
        # 1920x1080p @ 23.976Hz (EIA/CEA-861B)
        # 1920x1080i @ 50Hz (EIA/CEA-861B)
        # 1920x1080i @ 60Hz (EIA/CEA-861B)
        # 1920x1080p @ 59.94Hz (EIA/CEA-861B)
        # 1920x1080i @ 59.94Hz (EIA/CEA-861B)
        # 1920x1080p @ 25Hz (EIA/CEA-861B)
        # 1920x1080p @ 29.97Hz (EIA/CEA-861B)
        # 1920x1080p @ 30Hz (EIA/CEA-861B)

    Option         "PreferredMode" "1920x1080 at 50"
    Option         "DPMS"
    Option         "ExactModeTimingsDVI" "True"
    Option         "NoLogo" "False"
    Option         "UseEDIDD" "False"
    Option         "UseEDIDDpi" "False"
    Option         "UseEDIDFreqs" "False"
    Option         "DPI" "200 x 200"


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "ION"
    Option "HWCursor" "false"
    Option  "ModeDebug"           "true"

Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "nvidia-auto-select +0+0; 1920x1080 +0+0"
    Option         "FlatPanelProperties" "Scaling = Native"

        SubSection "Display"
                Depth     24
                Modes "nvidia-auto-select+0+0" "1920x1080+0+0"
"1920x1080_60_0" "1920x1080_50" "1920x1080_30" "1920x1080_25"
"1920x1080_24" "1920x1080_60i" "1920x1080_50i"



More information about the mythtv-users mailing list