[mythtv-users] Mythbuntu 10.10 upgrade broke VDPAU

Lindsay Mathieson lindsay.mathieson at gmail.com
Sun Oct 24 12:29:16 UTC 2010

On 24/10/10 17:57, Jon Whitear wrote:
> I gather that this usually indicates the absence of of VDPAU libraries. I have removed and reinstalled the nvidia-current package (which is supposed to include the library) and tried installing from the Nvidia-supplied installer. I've also tried fixing a link like so (all suggestions served up by google.)
> sudo mv /usr/lib/libvdpau_nvidia.so /usr/lib/libvdpau_nvidia.so.OLD
> sudo ln -s /usr/lib/nvidia-current/vdpau/libvdpau_nvidia.so /usr/lib/libvdpau_nvidia.so
> jon at fe2:~$ ls -al/usr/lib/nvidia-current/vdpau/
> total 1624
> drwxr-xr-x 2 root root    4096 2010-10-23 18:37 .
> drwxr-xr-x 6 root root    4096 2010-10-23 18:37 ..
> lrwxrwxrwx 1 root root      20 2010-10-23 18:37 libvdpau_nvidia.so ->  libvdpau_nvidia.so.1
> lrwxrwxrwx 1 root root      28 2010-10-23 18:37 libvdpau_nvidia.so.1 ->  libvdpau_nvidia.so.260.19.06
> -rw-r--r-- 1 root root 1650456 2010-10-05 02:37 libvdpau_nvidia.so.260.19.06
> The Xorg log makes no mention of VDPAU. I have a 9500GT with 1GB RAM. I've run out of ideas. Any help is appreciated.

Hi Jon, I ran into this exact same problem, there seems to be some issue 
with the nvidia packages in 10.10 - I noticed errors with the vdpau 
libraries when I reinstalled nvidia-current from the command line, but I 
could not fix them. OpenGL worked fine though.

Where you using JYA's avernad repo's? perhaps there's some odd 
iteraction between JYA's and ubuntu's repos.

Anyway, how I worked around it was to purge the packaged nvidia install 
and install the nvidia drivers manually - download from here:


If you need a hand on running the install, just post here. Its not 


More information about the mythtv-users mailing list