[mythtv-users] Todays update broke 0.24. Backend not running. HELP

Douglas Peale Douglas_Peale at comcast.net
Wed Oct 20 16:58:11 UTC 2010

I was running 0.24 from http://ppa.launchpad.net/mythbuntu/0.24/ubuntu

I updated today, and it tried to force me back to 0.23.1. I managed to find the YouMustBeThisTallToRide option so I could keep
it at 0.24 but the update failed

After rebooting, (a new kennel was in todays update) there was one more thing to update: libmyth-0.24-0, but attempting to do
this update fails.

It suggested I remove all ppa (no chance if I want to keep running mythTV) and run "apt get install -f". I tried that with the
following result:

$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  python-bugbuddy python-gnomedesktop python-evince libnspr4-dev libgexiv2-0 libavutil-extra-49 python-totem-plparser kdesudo
libpoppler5 libpoppler-glib4 firefox-3.0 update-manager-kde
  python-mediaprofiles libqt4-webkit python-metacity python-gtop
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
14 not fully installed or removed.
Need to get 0B/11.9MB of archives.
After this operation, 32.7MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 331669 files and directories currently installed.)
Unpacking libmyth-0.24-0 (from .../libmyth-0.24-0_0.24.0+fixes26902-0ubuntu0+mythbuntu2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libmyth-0.24-0_0.24.0+fixes26902-0ubuntu0+mythbuntu2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libmythfreemheg-0.24.so.0.24.0', which is also in package libmyth-0.23-0
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried running the synaptic package manager and installing libmyth-0.24-0, but that resulted in this error:

E: /var/cache/apt/archives/libmyth-0.24-0_0.24.0+fixes26902-0ubuntu0+mythbuntu2_amd64.deb: trying to overwrite
'/usr/lib/libmythfreemheg-0.24.so.0.24.0', which is also in package libmyth-0.23-0 0.24.0~trunk26882-0ubuntu0~mythbuntu2

libmyth-0.23.0 is still installed. I tried uninstalling that, but it won't let me uninstall that without also instaalling
libmyth-0.24.0, and then it errors out because there is a file both are trying to overwrite.

How do I untangle this mess?

More information about the mythtv-users mailing list