[mythtv-users] KWorld DVB-T PC160-2T Card Not Responding to probe

Anthony Rooney rooneyo at iinet.net.au
Tue Oct 5 10:22:46 UTC 2010

Hi David

I will run dmesg and advise what I find.
I live in Adelaide (5 KMS from GPO) in a good reception area and the Divico
Fusion in the same computer running Ubuntu 10.04 and Myth 0.23 could pick up
all channels without any issue.

Thanks for your advice.

Kind Regards


-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of David Whyte
Sent: Tuesday, 5 October 2010 9:02 AM
To: Discussion about MythTV
Subject: Re: [mythtv-users] KWorld DVB-T PC160-2T Card Not Responding to

On Mon, Oct 4, 2010 at 10:57 PM, Anthony Rooney <rooneyo at iinet.net.au>
> Hi
> I downloaded and installed fw 5.10 and the probe worked and I was able 
> to install the card.
> I associated it with the Shepherd video source and when I started Live 
> TV I could see my 1st Tv channel with the Kworld however was not able 
> to change channel - unable to lock on to a channel even though it 
> reported a good signal 77%.  I stopped and started the front end a few 
> times but the performance of the KWorld dual tuner was hopeless 
> compared to the previous card I tested with a single tuner Divico 
> Fussion.  The KWorld works fine in windows connected to the same antenna
> I downloaded FW 4.65 on advice from this forum as a user reported an 
> issue with 5.10 but this is exactly the same - cannot lock on to a 
> channel.  So far the Kworld PC 160 is useless with mythTV.
> I purchased the Kworld to get a dual tuner having checked in advance 
> if it is supported with MythTV however I guess it depends on what you 
> determine "SUPPORTED" means?
> Any suggestions?

Firmware version 4.95 is the default on with Ubuntu 9.10.  Perhaps try
downloading that manually from the repository and put that in its place.

Are you sure that firmware version 4.65 was actually applied to the card?
These PCI cards are very finicky on how they upload the firmware.  You need
to check the output of dmesg to see what happened when the card was detected
by Ubuntu.

Where abouts in Australia are you?  I assume you have good reception
mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list