[mythtv-users] DirecTV HTTP Server

Greg Oliver oliver.greg at gmail.com
Mon Nov 22 01:35:12 UTC 2010

On 11/21/2010 04:07 PM, jmk wrote:
> Hi,
> I've been using the DirecTV HTTP service for channel changing for the
> past few weeks. Unfortunately, it seems to have died on me sometime this
> past week. Connections to 8080/tcp either give a 403 (forbidden) or
> simply drop the connection (which is the most frequent result). I've
> bounced the box a few times with no improvement. I've also reconnected
> my USB cable that I used for years and that's failing now (excessive
> retry error).
> My only guess at this point is that DirecTV fubar'd the box. It reports
> that it was updated to 0x4440 on Tuesday 11/16 2:25AM. This corresponds
> to when I started seeing issues.
> Has anyone else run into these problems? Is there a way to rollback
> firmware on a H21 and then lock it at that version?

I was looking into this earlier today.  I have (2) HR23 and (1) HR21.

The 23s still work as usual, but the 21 never actually returns anything 
(even though the channel changes).  By wrapping the LWP call into an 
eval, it will let the channel change script return after a timeout. 
Currently it will just sit there forever I guess.

I moved a revo/hdpvr to a different receiver since I had to leave.  A 
note as well.  I have the whole home dvr service from them, and it *does 
not* use those ports.  It is all encrypted https traffic on a separate 

More information about the mythtv-users mailing list