[mythtv-users] mythweb 0.24 fixes svn Revision: 27219

Andrew Junev a-j at a-j.ru
Sun Nov 14 23:15:52 UTC 2010

Hello Lasse,

Sunday, November 14, 2010, 6:43:05 PM, you wrote:

> Greetings,

> i have some trouble with mythweb after upgrading to mythtv 27219,
> there were no problems in 0.23 which i ran upto a few hours ago. the
> main mythweb page lists the directory contents of the mythweb
> directory, which is a problem :) i did clean out the old files before
> copying in the 0.24 ones

> when i try to klick on the mythweb.php, in that directory i get the
> error below, and a blank page.

> apache error.log
> [Sun Nov 14 16:33:05 2010] [error] [client] PHP Fatal
> error:  Failed to open translation file:
> modules_path/_shared/lang/English.lang in
> /var/www/mythweb/classes/Translate.php on line 172, referer:

> if i set the alias in the apache mythweb conf file, i end up with a
> blank page, and no error.

> I run this on ubunto 10.4, and the regular frontends work. its just
> mythweb acting up

> Anyone that has an idea?

I faced the same issue when I made a fresh installation of MythTV
(from rpmfusion repo) on a fresh Fedora 14 machine. It is still
0.24-RC2 there, but I guess it doesn't really matter in this case.
I think the key here is the path apache complains about:


I checked it on my machine and this path was really not correct - the
correct one was:


So I just made a symlink:

ln -s /usr/share/modules /usr/share/modules_path

After that mythweb is working fine with alias configured in apache
mythweb configuration. 

Hope this helps...

Best regards,

More information about the mythtv-users mailing list