[mythtv-users] Setting up joystick

Gabe Rubin gaberubin at gmail.com
Sun Nov 7 00:00:25 UTC 2010

On Sat, Nov 6, 2010 at 4:03 PM, Gabe Rubin <gaberubin at gmail.com> wrote:
> Hi list,
> I came across a generic wireless joystick that I had lying around.  I
> am trying to set it up with my mythbox so I can eventually use
> mythgames.  Unfortunately, I don't know the manufacture, it is
> generic, but I see this in dmesg when I plug the USB receiver in:
> usb 3-3: new low speed USB device using ohci_hcd and address 2
> usb 3-3: New USB device found, idVendor=1345, idProduct=0003
> usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
> usb 3-3: Product: USB  Joystick
> usb 3-3: Manufacturer: LuenKeung Co.,Ltd
> usb 3-3: configuration #1 chosen from 1 choice
> input: LuenKeung Co.,Ltd USB  Joystick as
> /devices/pci0000:00/0000:00:12.0/usb3/3-3/3-3:1.0/input/input3
> generic-usb 0003:1345:0003.0001: input,hidraw0: USB HID v1.10 Joystick
> [LuenKeung Co.,Ltd USB  Joystick] on usb-0000:00:12.0-3/input0
> I think I can connect the joystick to the receiver (by hitting the
> f.connect buttons on both devices at the same time), but when I do cat
> /dev/input/js0 and press buttons, there seems to be no response.  Same
> with when I do  jstest /dev/input/js0.
> I am running fedora 12.  I tried issuing these commands as well:
> modprobe joydev
> modprobe iforce
> and ran both tests with no success.  Is there something I am missing?

I tried the joystick on my Windows 7 machine.  That does not seem to
recognize any input either (but it does recognize the receiver).  I am
starting to think that even though the joystick worked at some point,
it no longer does.  Also, found it is a KILLERFORCE PAD RF 2.4Ghz

More information about the mythtv-users mailing list