[mythtv-users] Hauppauge WinTV NOVA HD S2 sees signal but not channels

Thomas Ulich thomas at ulich.org
Sun May 30 12:02:16 UTC 2010


thanks to all who replied to my post (see below).  The behaviour of my 
card might be explained, after all, by a hardware problem.  I could not 
get scan (dvbscan) to find any channels, but mythtv reported good signal, 
but also didn't find channels.

Afterall I tried the DVB-T card alone, no DVB-S card in the machine.  It 
worked.  Then I tried the DVB-S card alone.  It did not work.  Then I 
changed the PCI slot, used the DVB-S card alone, and it worked!  Yeah!

When I had the channel.conf, I swapped slots again. It does not work. 
Then I tried both card, but with reversed PCI slots as initially.  Then 
the graphics card went black...

I have a fanless PC here as a testbed before on loan from a friend.  I 
wanted to test mythtv before spending too much money.  This PC I learnt 
now has a very small external power supply (84W).  So my suspicion is that 
either the power supply can't handle two cards including providing phantom 
power to the LNB in addition to video card and harddisk.  Or it's an 
interrupt problem, but since the cards almost worked and otherwise I have 
experienced some random crashes, I think power supply.

I will make more tests in that direction and post the results here when 
done.  Maybe it's of benefit to someone running into similar problems.

Thanks again, and all the best,


On Sat, 29 May 2010, Thomas Ulich wrote:

> Hi,
> my Hauppauge WinTV NOVA HD S2 (DVB-S/DVB-S2; similar to HVR-4000) does not 
> find any channels even though MythTV reports high signal and SNR levels. 
> Here's my setup and what I have done so far:
> - Fresh install of Ubuntu 10.04 with mythtv 0.23
> - Kernel upgraded to 2.6.32-22-generic, all other upgrades done, installed
>  proprietary hardware driver
> - 2 DVB Cards installed:
>  Hauppauge WinTV NOVA HD S2 - udev-fixed to /dev/dvb/adapter20
>  Hauppauge WinTV NOVA TD-500 - udev-fixed to /dev/dvb/adapter1[01]
>  (dual-tuner card)
> - Read http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-4000
>  and ...
> - Downloaded firmware from (old address in URL above)
>  http://www.wintvcd.co.uk/drivers/88x_2_125_28070_WHQL.zip
>  Extracted binary; cmp'd with original /lib/firmware/dvb-fe-cx24116.fw:
>  they are identical.  dmesg tells me that:
> [  205.088404] cx24116_firmware_ondemand: Waiting for firmware upload 
> (dvb-fe-cx24116.fw)...
> [  205.088412] cx88-mpeg driver manager 0000:03:0e.2: firmware: requesting 
> dvb-fe-cx24116.fw
> [  205.120411] cx24116_firmware_ondemand: Waiting for firmware upload(2)...
> [  210.501279] cx24116_load_firmware: FW version
> [  210.501286] cx24116_firmware_ondemand: Firmware upload complete
> - Downloaded v4l driver from http://hg.kewl.org/pub/v4l-dvb-20100517
>  (also tried -20100130; makes no difference for me), disabled FireDTV,
>  compiled and installed successfully. depmod -a, reboot
> - Followed instructions on http://www.mythtv.org/wiki/DVB-S to enable LNB
>  in the backend-setup (UNIVERSAL (Europe))
> - Followed instructions on http://parker1.co.uk/mythtv_ubuntu.php and set
>  the timeouts to rather high 30000 ms for initial DVB-S search.
> - Defined two separate Video Sources, for EIT Terrestrial and EIT
>  Satellite.
> - Made input connections between cards and sources.
> - Scanned for channels on the terrestrial card: WORKS FINE, I can watch
>  DVB-T TV!
> - Scanned for channels on the satellite card. Again following advice from
>  http://parker1.co.uk/mythtv_ubuntu.php, I entered the following data on
>  the scan page:  Desired Services: TV -> Only Free: Unchecked -> Test
>  Decrypt: Checked -> Scan Type: Full Scan (Tuned)-> Frequency 11681000,
>  Pol vertical, SymRate 27500000, FEC=2/3, Mod QPSK, Inversion Auto,
>  Rolloff 0.35  (Astra-28.2E / Eurobird1)
> - Also tried: Only Free checked, Test Decrypt unchecked, and FEC=auto, but
>  results are all the same.
> PROBLEM: When starting the scan, I have immediately Signal 78% and SNR of 
> 74-78%, but the scan progress bar remains at 0% for half a minute, and then 
> jumps to 100% while displaying a pop-up window "Failed to find any new 
> channels!"
> Also, I tried to use scan and scan-s2 using option -5 (long timeouts), -l 
> UNIVERSAL (LNB) and correct adapter and frontend numbers together with the 
> Astra-28.2E and Eurobird1 config files.  Nothing.  Only messages "tuning 
> failed" and "filter timeout pid".
> I have a DVB-T/DVB-S set top box (w/o harddisk) in use with the same dish, 
> which works just fine and can see many hundred DVB-S channels.  I chose the 
> frequency setting above, because according to that box it's a strong signal.
> After hours of g**gling the mailing lists etc I am running out of ideas what 
> I could try.
> Thank you very much in advance for any ideas how to go from here.
> All the best,
> Thomas

All the best,


Thomas Ulich --- thomas at ulich.org --- www.ulich.org

More information about the mythtv-users mailing list