[mythtv-users] MPEG2->MPEG2 transcode of OTA recording with bookmark borks keyframe index

Richard Shaw hobbes1069 at gmail.com
Thu May 27 03:37:10 UTC 2010

Ok, I tried to keep the subject as succinct as possble, but has anyone
else had this problem?

The long version:
I have a recording of "The Ghost Whisperer" which I'm guessing had
some transmission errors in the stream because any time I tried to
skip ahead it would just exit playback and go back to the recording
menu. Actually, I've been having a lot of issues with *some*
recordings either completely locking up video, or hang for a
significant amount of time before responding to ESC, or most recently
this problem.

So I saved a bookmark so I could get back to where we left off,
scheduled a lossless MPEG2->MPEG2 transcoding job, waiting for it to
finish and played the recording again.

Now I could skip forwards and backwards, but only to the point where I
saved the bookmark, approx. 2:26 into the recording. If I didn't do
anything the recording would continue to play but I could no longer
skip forward.

We decided to just watch it, commercials included, as the WAF was
dropping rapidly but then around 45 min. into it the video was
stuttering a lot so I took a second shot at transcoding but this time
without a bookmark and after that the OSD showed the full recording
length and playback and skipping forward worked.

I skimmed through trac to see if there was an existing bug report but
I didn't see anything that looked appropriate.

Version Info:
Fedora 12 x86_64
MythTV 0.23-1 (rpmfusion-testing repo)
Nvidia 8400GS PCI-E video
Playback using VDPAU with 195.36.24-1.fc12 nvidia driver version.


More information about the mythtv-users mailing list