[mythtv-users] What replaces irw when using atilibusb for the remote receiver?

Don Brett dlbrett at zoominternet.net
Sat May 15 03:01:24 UTC 2010

Jarod Wilson wrote:
> On Wed, May 12, 2010 at 10:26 PM, Don Brett <dlbrett at zoominternet.net> wrote:
>> Jarod Wilson wrote:
> ...
>>> All you need to do is a bit of editing in /etc/sysconfig/lirc. Set
>>> LIRC_DRIVER="devinput" and
>>> LIRC_DEVICE="/dev/input/by-id/usb-PHILIPS_ATI_Theater_Remote_Receiver-event-kbd"
>>> in there, and from the lirc-remotes package (yum install lirc-remotes,
>>> if need be), grab /usr/share/lirc-remotes/devinput/lircd.conf.devinput
>>> and copy it to /etc/lirc/lircd.conf. Start up lircd, then give irw a
>>> try, and it should spit out key names for you. Then its just a matter
>>> of mapping those appropriately for mythtv via your lircrc file.
>>> In the future, when mythtv grows native linux input layer support,
>>> things will (hopefully) magically Just Work right out of the box... :)
>> OK, that was easy.  I have most of the buttons giving me message in irw now.
>>  Most of the buttons worked in MythDora also (but not the back button), so I
>> made a couple of picks in the infrared setup.  Now the buttons don't work so
>> well in irw anymore; I don't think I chose wisely.  Any suggestions on which
>> selections for remote control model and override?
> You could try claiming its an imon device, since that's one that I
> know pretty well... Figure out what irw reports for each key, then
> edit ~/.mythtv/lircrc to alter any of the current settings in there to
> better match. I haven't a clue exactly what remote you've got, but
> input layer is input layer is input layer, so that same
> lircd.conf.devinput works for all devices, its just a matter of
> setting up appropriate mappings in ~/.mythtv/lircrc to make it behave
> the way you want.
I'm 90% home, but I had a small diversion.  I picked a remote and driver 
through the Infrared Devices menu and it replaced this:


....with this

LIRCD_OPTIONS='-r -H devinput -d /dev/input/event2'

When that happened, irw gave me buttons, not codes (press 1,2, 3 and it 
displays 1,2,3); so that's solved.  Now most of the buttons give codes 
in irw, but some do nothing.  I tried playing with /etc/lirc/lircd.conf 
but it must not be the right file to edit...nothing I did had any 
effect.  I would like to experiment with the codes, do you know which 
file I need to edit?

More information about the mythtv-users mailing list