[mythtv-users] No GUID showing up in Firewire capture card setup

Bob Shanteau rmshant at gmail.com
Sat May 15 00:55:06 UTC 2010

Greg Woods wrote:
> How about dmesg? You should see something like this:
> # dmesg | fgrep firewire
> firewire_ohci 0000:04:00.0: PCI INT A -> Link[LNEB] -> GSI 19 (level,
> low) -> IRQ 19
> firewire_ohci 0000:04:00.0: setting latency timer to 64
> firewire_ohci: Added fw-ohci device 0000:04:00.0, OHCI version 1.10
> firewire_core: BM lock failed, making local node (ffc1) root.
> firewire_core: phy config: card 0, new root=ffc1, gap_count=7
> firewire_core: created device fw0: GUID 001b8c00000101bd, S400
> firewire_core: created device fw1: GUID 00152ffffeda33ac, S400
> firewire_core: created device fw2: GUID 0023a3fffe547059, S400

Here's the result on my old FIC AU13 motherboard:

# dmesg | fgrep firewire
firewire_ohci 0000:00:0d.0: PCI INT A -> Link[APCM] -> GSI 22 (level, 
high) -> IRQ 22
firewire_ohci 0000:00:0d.0: setting latency timer to 64
firewire_ohci: Added fw-ohci device 0000:00:0d.0, OHCI version 1.10
firewire_ohci: isochronous cycle inconsistent
firewire_core: created device fw0: GUID 0040ca07010422ec, S400
firewire_core: giving up on config rom for node id ffc1

And here's the result on a Startech 2+1 Firewire PCI card with a VIA 
VT6307 chip that I just from OfficeDepot.com:

[mythtv at localhost ~]$ dmesg | fgrep firewire
firewire_ohci 0000:01:09.0: PCI INT A -> Link[LNKB] -> GSI 19 (level, 
low) -> IRQ 19
firewire_ohci: Failed to reset ohci card.
firewire_ohci 0000:01:09.0: PCI INT A disabled
firewire_ohci: probe of 0000:01:09.0 failed with error

> If you really aren't getting anything, it may be that your firewire chip is not supported in Linux. I had a devil of a time getting a firewire card that worked. The one I am using doesn't work for any large data transfer (such as connecting my camcorder), but it works fine for channel changing.

You can't be serious!!!!! You mean that I have to buy a bunch of 
Firewire cards before I find one that works in Linux???? That makes me 
very unhappy.

At least tell me what card you're using so I can buy one like it.

> Or, as someone else suggested, perhaps the cable boxes don't actually have active firewire ports.

I checked with Comcast and they showed me the hidden diagnostic menu 
that shows the firewire ports are enabled but not active.

> Have you tried connecting any other firewire devices to see if they at least show up in plugreport?

The cable box is the only Firewire device I have.

Bob Shanteau

More information about the mythtv-users mailing list