[mythtv-users] No GUID showing up in Firewire capture card setup

Bob Shanteau rmshant at gmail.com
Fri May 14 20:40:07 UTC 2010

Jarod Wilson wrote:

> If all you see is /dev/fw0, then only the firewire controller itself 
> is being set up, the cable box isn't being seen on the bus -- thus no 
> firewire guid showing up in myth. Sounds like the firewire port is 
> probably disabled on that box. Not sure how to get it enabled, but 
> technically speaking, it's supposed to be (per fcc regs), if you ask 
> for it to be. Making someone at Comcast understand what you're talking 
> about can be an exercise in pain and suffering though.

I called Comcast and the rep was actually quite helpful. He first told 
change to an unencrypted channel. Then he told me to turn off the 
DCH3200 and then immediately hit OK/Select on the remote. That brought 
up a hidden diagnostics menu. Item d11 in the menu was Interface/Port 
Selection. Selecting that took me to page 1 of 4, which had a list of 
devices and a couple of columns labeled Enabled and Active. For 1394, 
Enabled = Yes and Active = No. The rep told me that the Firewire port 
was enabled but was not communicating with anything.

I then went to page 3 of 4, which is labeled 1394. This had the 
following entries:

Active Ports:            0
Data Xmission:           Not Active
5C Implementation:       No
Copy Control:            Copy Free
Cycle Master Node:       No
IRM Node:                Yes
Root Node:               No
Loop Detected:           No
EUI-64:   0X991C11FFFEA6E812

Connected Devices:      02
Device ID

The Comcast rep did not know what anything on this page meant, other 
than that the Firewire port was enabled but not active.

I just tried going into the Channel Card Setup in MythTV, but I am still 
not seeing an entry in the GUID box.

Is there another way besides MythTV to see if my Firewire controller is 
communicating with the DCH3200? Another Linux program or Windows perhaps?

BTW, you say that the fact that I see /dev/fw0 means that my Firewire 
controller is working, but according to the MythTV Wiki on Firewire, 
running a program called "plugreport" is supposed to tell me about all 
Firewire devices on all buses. When I run it, though, I get nothing, 
just a new command line. What do you see when you run plugreport?

Bob Shanteau

More information about the mythtv-users mailing list