[mythtv-users] Problems with vdpau decoding HD content

Scott Russell list-mythtv at bluecamel.eml.cc
Thu May 13 15:15:06 UTC 2010

On May 13, 2010, at 10:37 AM, Johnny Walker wrote:

> On Thu, May 13, 2010 at 8:59 AM, Tom Lichti <redpepperracing at gmail.com> wrote:
>> On Thu, May 13, 2010 at 9:26 AM, Scott Russell
>> <list-mythtv at bluecamel.eml.cc> wrote:
>>> On May 13, 2010, at 1:14 AM, Scott wrote:
>>>> This is a general query to help me with my troubleshooting of a playback problem on my FE.
>>>> I have an ASRock 330 ION loaded with Mythbuntu 10.04 and the 0.23-fixes SVN 24572. The system uses the VDPAU Normal profile and is configured for 512MB of GPU RAM in BIOS.
>>>> Playback with both recorded 720p and 1080i (OTA ATSC from a HDHR) shows seems to run into a glitch. The show starts off fine and pausing, FF/RW, and commercial skip all work fine. At some point, usually 12-30 minutes, the video starts jumping and sometimes the audio too. I see "prebuffering pause" messages logged in mythfrontend.log.
>>>> To resolve the problem I have to reboot the system. To be sure, the following does NOT resolve the problem:
>>>> 1) pause/unpause the show
>>>> 2) stop/start playback again
>>>> 3) exit mythfrontned and start mythfrontend again
>>>> 4) exit X11 and start it again
>>>> Thoughts? Is anyone else having trouble with vdpau and HD recordings on 0.23?
>>> Following up on my own status, I've tried the following additional steps. These have not resolved the problem:
>>> 1) Enabled OpenGL sync in MythTV settings
>>> 2) Verified 512MB of video memory was set in BIOS
>>> 3) Added UseEvents On to the xorg.conf
>>> 4) Reset FE back to default prefs (removed from FE prefs from converg.settings table on the BE)
>>>        - Set theme to blue-abstract
>>>        - Set audio out to ALSA:hdmi
>>>        - Enabled DTS and AC3 pass through
>>>        - Enabled VDPAU Normal profile
>>> A log of the problem before I did these latest changes is available at:
>>> http://pastebin.com/GZDB18CU
>>> I started playback of a 720p source at time code 2010-05-11 22:13:08.711 and the video problem starts at time code 2010-05-11 22:18:17.811.
>>> -- Scott
>> Have you checked your network? I had a similar problem, and the cause
>> was having three switches between the frontend and the backend. With
>> them both on the same switch, I don't see the problem anymore. I am on
>> Gig-E as well, which I think helps a lot as well.
>> Tom
> There's an aggregate of information on this issue available at
> http://www.mythtv.org/wiki/Troubleshooting:Prebuffering_pause

I found that list and I was excited but haven't yet solved  it. It did give me a couple of more checks

1) CPU Starvation: confirmed in TOP that I was seeing 3-4% CPU usage when playing both 1080i and 720p video. The logs confirmed VDPAU was active as well. So most of the work should be happening on the GPU. I don't know of any tools to check for GPU starvation though.

2) IO WAIT - This is over the network from a BE to a FE. The BE is idle except for streaming to the FE for playback. I need to check my network though..

3) Seek Table -  doesn't seem likely based on the symptoms. I a good next step would be to identify one show that has the problem, repair the seek table, and rewatch it again. I'm not feeling this is the issue though... I wouldn't expect a reboot is needed to clear the problem. It's almost like something in the VPDAU/NVIDIA driver is messed up at that point.

4) Audio Issues - Happens with stereo as well as with 5.1. I'm not doing any upmixing.

5) Network streaming - this gives me pause.... (pun intended!) I don't have the "Always stream recordings" option checked. In 0.23 will the FE attempt to mount the BE shares and read off the share or will the FE stream directly from the backend? Is this option still applicable in 0.23?

6) Network Config - I will simplify my network config and see if the problem still exists. I will also take some traces and look for dup acks, retransmits, and out of order packets which are typical on a noisy network.

7) Scheduler - checked this and USER_SCHED is not used. CFQ scheduler is used. I'm not thinking this is the problem right now.

-- Scott 

More information about the mythtv-users mailing list