[mythtv-users] Mythweb times off by an hour

mythtv at blandford.net mythtv at blandford.net
Tue May 11 21:35:56 UTC 2010

On 05/11/2010 02:35 PM, mythtv at blandford.net wrote:
> On 05/11/2010 02:20 PM, Oliver Maunder wrote:
>> Hi
>> I'm in the UK and since the clocks changed to BST, all times in
>> Mythweb have been an hour out, stuck in GMT. This includes the
>> timestamp at the top of the screen and all the times on the listings
>> page. The time on my backend is correct, and the webserver is running
>> on the same machine as the backend.
>> In the past people have had similar problems because of the way PHP
>> handles timezones, and specifying a timezone in the php.ini file fixes
>> the time. However, I don't think this is the same issue. Only Mythweb
>> displays the wrong time - other PHP pages are OK.
>> For example a simple file containing
>> <?php echo(date('h:i:s')) ?>
>> shows the correct time.
>> Does anyone know what's going on here, and how I can diagnose this?
> I had a similar problem in the US for Arizona. We observe day light
> savings time and mythweb would get it wrong half the year.

Bah, we do NOT observe day light savings time.

> Adding this to php.ini worked for me.
> [Date]
> ; Defines the default timezone used by the date functions
> ; http://www.php.net/manual/en/datetime.configuration.php#ini.date.timezone
> ;date.timezone =
> date.timezone = "America/Phoenix"
> Maybe something like would work for you.
> Michael
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list