[mythtv-users] optimize_mythtvdb.pl stalling on upnpmedia with backend running

Michael T. Dean mtdean at thirdcontact.com
Sat May 8 19:21:18 UTC 2010

On 05/08/2010 02:16 PM, Steven Adeff wrote:
> On Sat, May 8, 2010 at 1:54 PM, Michael T. Dean wrote:
>> On 05/08/2010 12:47 PM, Steven Adeff wrote:
>>>   interesting thing going on. if mythtvbackend is running
>>> optimize_mythtvdb.pl "stalls" in the upnpmedia table, cpu time for
>>> mysql is zero (unlike on the other tables) and it will just sit there.
>>> If I stop running mythtvbackend then optimize_mythtvdb.pl runs fine.
>>> It also causes mythconverg_backup.pl to not actually do anything when
>>> running (the backup dump file stays at 0bytes and no cpu time is used
>>> by mysql). Again, if mythtvbackend isn't running it goes off without a
>>> hitch.
>>> anyone have any idea why this is occuring?
>> Sounds like something is locking the upnpmedia table.  A UPnP scan is only
>> done once every 30min by default, but configurable with the mythtv-setup
>> setting:
>> Upnp Media Update Time
>> The number of minutes between mythbackend checking for new videos to serve
>> via upnp. 0 = Off.
>> I could see the situation you're describing happening if something causes a
>> scan to take longer than 30min--i.e. symlink recursion or something.
>> I'd recommend turning off the UPnP scan (master backend restart required)
>> and see if that "fixes" the issue.  If so, you should check out what you
>> have it scanning and look for some issues in it.
>> Alternatively, there may be more-critical issues with the table that prevent
>> its access--for example, missing binary data files, etc., that can't be
>> fixed with a REPAIR TABLE.  You can run mysqlcheck and see if it gives you
>> more info.
> awesome, so i changed the upnp setting to 0 and the optimize and
> backup are now running fine.
> so to fix it...
> the option above it the upnp scanning time interval (WMP something or
> other) was set to "recordings", and the upnp *was* set to 30. how can
> i figure out why this is causing upnp to have issues? is it something
> I should see in the backend logs or?

Yeah, check the table with mysqlcheck, then check the backend logs.  If 
neither reveals any issues, check the recordings directories for symlink 
loops or similar.  Also check your storage groups configuration.


More information about the mythtv-users mailing list