[mythtv-users] IOBOUND errors after kernel upgrade from 2.6.31 to 2.6.32

Tom Dexter digitalaudiorock at gmail.com
Fri May 7 16:16:22 UTC 2010

On Sat, May 1, 2010 at 2:17 PM, Tom Dexter <digitalaudiorock at gmail.com> wrote:
> This is interesting...I'm finding a lot of stuff about a change to
> EXT4 in 2.6.32 that does in fact introduce a performance regression:
> http://www.phoronix.com/scan.php?page=article&item=linux_perf_regressions&num=2
> Interesting.  If I start getting the IOBOUND errors again once the
> drive is more full I may try adding that nobarrier mount option and
> see if they go away.  My EXT4 partition is only used for recordings
> (nothing where data integrity is critical like the DB) where loosing a
> cached write in a power outage is no issue...hell...the whole
> recording is worthless at that point.
> Tom

After a lot of testing here's what I've ultimately discovered:  The
kernel changes that are causing me problems are the changes that
occurred between linux-2.6.31-gentoo-r6 and
linux-2.6.31-gentoo-r10...so this wasn't specifically with 2.6.32.
When I tried linux-2.6.31-gentoo-r10 I actually got some IOBOUND
errors when recording only one HD show with nothing else going on even
with good ext4 options.  For the last two days I've been running
2.6.31-gentoo-r6 again, and even with three shows recording, the
frontend watching another, and two of the recordings commflagging in
real time it worked like a clock both nights.

The ext4 changes referred to in the above link were made between those
two versions.  The specific issue discussed there however should be
resolved with nobarrier, which didn't resolve it for me...nor did
changes such as data=writeback,commit=60 etc.  As a matter of fact, it
looks to me as though the changes to the ext4 code between those
versions was way more extensive than the changes going to 2.6.32.
They have to have been significant seeing how linux-2.6.31-gentoo-r6
works for me even using the default ext4 settings, which is basically
just asking for trouble.

If it weren't such an awful undertaking I'd try switching back to
ext3...but who knows, they may have changed that in ways that would
cause me problems as well.  At this point I guess I have to stick with
linux-2.6.31-gentoo-r6 unless I can figure out a good way to shoe-horn
a third hard drive into my Dell 4600 for the OS partition.  I'm
assuming that's most likely at the root of all this...have the
os/database partition sharing a drive with my recording LVM...I'd sure
hate to go through all that, risking heat/power issues etc, and have
*that* not fix it.


More information about the mythtv-users mailing list