[mythtv-users] MythWeb quits during Recorded Programs listing

Mike Perkins mikep at randomtraveller.org.uk
Thu May 6 09:29:57 UTC 2010

Ed W wrote:
> On 05/05/2010 20:07, Yeechang Lee wrote:
>> [1] For those curious: My router's DNS server is the only one in my
>> home network. Since installing 10.6, my Macbook randomly fails to
>> resolve local hostnames (those without a domain name), thinking they
>> are external;
> Could be a number of reasons for this - Wireshark will help narrow down 
> a few of them...
> Could it be that you have a primary and secondary nameserver setup?  
> Sometimes the mac seems to switch and use the other one for a while...
> Otherwise use some traffic sniffer and see what DNS addresses it's 
> actually trying to resolve - the mac does dns resolution with a bunch of 
> appended suffixes and you will probably get a few clues based on what 
> it's really trying to resolve
I've read an issue recently with Mac OS where a problem can be caused with DNS 
if AAAA records can be/are returned from an upstream server. The Mac can 
automatically assume IPv6 even if it isn't available. This I believe is due to a 
different interpretation of an RFC regarding returns of AAAA records. The end 
result is immense delays in the system, even affecting other kit on the network.

As I have neither Mac boxes at home nor use IPv6 I only read through this report 
for professional curiosity, which I'm afraid explains the vagueness. But it 
sounds like it may be what you're experiencing.

Ah! Found a linky: http://apple.slashdot.org/article.pl?sid=10/05/04/2029255

Make of that what you will. My explanation above might not be accurate.


Mike Perkins

More information about the mythtv-users mailing list