[mythtv-users] How to ensure STB is on

Jerry Rubinow jerrymr at gmail.com
Tue May 4 17:19:36 UTC 2010

On Tue, May 4, 2010 at 9:54 AM, George Galt <george.galt at gmail.com> wrote:

> > George (and Christian), I just tried sa3250 again, to no avail.  The
> status
> > command returns the same codes whether the STB is on or off.
>  Specifically,
> > sa3250cmd -v -n 0 status returns:
> >   Sending Command: 0x01FFB27F
> >   Success, Response: 0x0CFFB270
> > return code: 2
> > George, what does it say for you in the on and off states?
> > I just tried majoridiot's program, and it will change channels fine when
> the
> > STB is on, but does nothing when it's off, using either:
> > mythchanger -f 6 -P -c 100
> > and
> > mythchanger -f 7 -P -c 100
> > -Jerry
> > _______________________________________________
> > mythtv-users mailing list
> > mythtv-users at mythtv.org
> > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> >
> >
> Jerry:
> Interesting, I never really worried about using it to try to turn
> things off, but here are the responses when I tried to use it to turn
> the STB off:
> [snip]
> I wasn't able to physically turn the device off and test (my wife was
> using the system and didn't want me "playing" with it), but it looks
> like sa3250cmd always leaves the STB in the "on" condition, regardless
> of whether you use "on" or "off".  I'll see if I can't get a few
> minutes tonight to turn the STB off and see what sa3250cmd does.
> In any event, all I know is that since I've started using sa3250cmd
> (about 6 weeks), I haven't missed a single recording because the STB
> was off.  Before that, it was usually 3 or 4 per month.
> NOTE TO CHRISTIAN: If the above results weren't what you were
> expecting, I'd be happy to work with you on getting your program to
> work with the Motorola QIP6200.


Thanks for doing those tests.  For me, running sa3250cmd with the on command
causes the power to toggle, whatever the current state of the STB, and
running it with the off command does nothing.  You're sure the power light
doesn't go off if you run sa3250cmd on when the box is already on?

Christian, I too would be happy to help however I can in getting it work
with the QIP-6200.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100504/e026e763/attachment.htm>

More information about the mythtv-users mailing list