[mythtv-users] xmltv-proc-nz fails when run from user crontab

Stephen Worthington stephen_agent at jsw.gen.nz
Tue May 4 01:31:45 UTC 2010

I have been running my EPG script manually (from user stephen) while I
tweaked it, and it was working fine.  Now, when I am trying to run it
from user stephen's crontab, xmltv-proc-nz (0.5.6) is failing:

Running xmltv-proc-nz on the Freeview data
Movies: TMDB module not found.
Traceback (most recent call last):
  File "/usr/local/bin/xmltv-proc-nz", line 551, in <module>
    tree = ElementTree.XML(data)
  File "<string>", line 86, in XML
SyntaxError: no element found: line 1, column 0
xmltv-proc-nz failed, rc = 1

The line in the script that runs xmltv-proc-nz is this:

/usr/local/bin/xmltv-proc-nz freeview.xml >temp.xml

Line 86 in the freeview.xml file is the start of the first <programme>
element after the <channel> elements.  If I again run the script
manually immediately after the crontab job fails, it works correctly.

I have no experience with Python or user crontabs, so I am hoping
someone out there will be able to give me a clue as to what this might

Also, how do I install the TMDB Python module?  I have tried a number
of things, but Python is still not finding it.  Is there a directory I
can just copy TMDB.py to, or is there something else I need to do to
get Python to recognise the module?  I am using Mythbuntu 9.10.

More information about the mythtv-users mailing list