[mythtv-users] Hauppauge PVR 350 and LIRC setting up

Marc Chamberlin marc at marcchamberlin.com
Wed Mar 31 21:22:07 UTC 2010

On 3/31/2010 1:11 PM, Jarod Wilson wrote:
> On Wed, Mar 31, 2010 at 3:36 PM, Scott<pickle136 at sbcglobal.net>  wrote:
>> On 3/31/2010 3:27 PM, Marc Chamberlin wrote:
>>>  From my searching around on the internet, and looking through this and
>>> other mail lists, I suspect this may have been answered somewhere, but I was
>>> not able to find any answers that I could grok.. (but lots of chatter about
>>> this remote!)  So with possible apologies in advance, I wonder if some kind
>>> guru could help me get my Hauppauge PVR-350 (gray) remote completely
>>> communicating with my media computer? I am running SuSE 11.2 x86-64 and I
>>> have installed version of lirc and version 0.8.5_2.6.31.5_0.1-4.4
>>> of the LIRC kernel modules. Following instructions I have also installed the
>>> kernel modules for lirc-i2c and lirc-dev.
>>> I am headed towards getting this working for mythTV. I have installed and
>>> configure the .lircrc, lircd.conf and the lirc file in /etc/sysconfig/
>>> following instructions as best as I could. I have got it going partially in
>>> that using ircat I can see the number keys are being recognized, as well as
>>> the volume up/down button but nothing else.
>>> I dunno what files or command outputs I should include so will wait until
>>> I hear further.. So anyone willing to guide me out of these woods? Or point
>>> me to a good website that explains in easy to understand terms what to do?
>>> Thanks in advance...
>>>   Marc..
>> what do you get from IRW?
>> most likely you see some keys but not other than the button definitions in
>> the lircd.conf arnt right. Install and look in the lirc remotes package you
>> might find the right remote info in there. (FYI theres an newer lirc 0.8.6
>> in a repo called vdr, but you your case that 0.8.5 should work)
>> lircrc only matter once you want to use the remote in lirc
> Not so sure about lirc 0.8.5 working here. I believe there were
> numerous i2c changes in 2.6.31 that made lirc_i2c non-functional, and
> they weren't fixed until after lirc 0.8.5 was released. I could be
> misremembering though. dmesg output from lirc_i2c module load time
> would likely say for sure.
Thanks Jerod for replying! Ouch! but yeah I am seeing lots of chatter 
elsewhere in my internet searches that seem to imply something is wrong 
with lirc_i2c but I cannot understand it nor discern any sort of fixes 
that apply to me...  Anywise I did a dmesg | grep i2c and will attach 
the results below...


Marc Chamberlin

  A man said unto the universe - "Sir I Exist!"
  "However" replied the universe
  "I do not see where that creates in me a sense of
  an obligation" S Crane.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dmsg_i2c.txt
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100331/d790a767/attachment-0001.txt>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 6464 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100331/d790a767/attachment-0001.bin>

More information about the mythtv-users mailing list