[mythtv-users] corrupt audio with time stretch and SPDIF passthrough

Jean-Yves Avenard jyavenard at gmail.com
Fri Mar 19 14:55:11 UTC 2010

On 19 March 2010 15:42, Andrew <mythtv at heathsworld.com> wrote:
> I got it now.  I am running:
> ~# cat /etc/apt/sources.list.d/avenard.list
> deb http://www.avenard.org/files/ubuntu-repos karmic release
> and need to change it to run trunk or bleeding.

Then this problems has been fixed. Those 0.22 packages run the same
audio code as found in trunk

Make sure that the packages installed are actually of this version,
and that you don't have say the mythbuntu repository activated.

Reading your earlier messages, it seems that you are running the
correct version...

If your amplifier supports DTS and AC3, and you are using SPDIF, make
sure you check both AC3 and DTS passthrough.

Regarding your issue of having to restart ALSA, it's puzzling then,
because the version you are running definitely fixes this

I'll have a test on my system and check I didn't break anything lately
with timestretch

More information about the mythtv-users mailing list