[mythtv-users] upgrade to 0.22 problems - database encoding

Scott Lipcon slipcon at gmail.com
Mon Mar 8 23:06:44 UTC 2010

>  Is this the dreaded partial corruption?    I've tried doing a partial
>> restore on top of the 0.21 blank.sql file posted here a few months ago and
>> it still is complaining - this time only 1 warning, in the oldrecorded
>> table.   Is there any way to find the "bad" characters in the database
>> backup and fix them by hand?   I really don't want to lose all my recordings
>> but I'm somewhat at a loss as to what to try next (besides re-installing
>> 0.21...)
> It is definitely corruption.  Because you had tried to reconfigure your
> MythTV box in 0.21 (where there was no way to test if the reconfiguration
> worked--as you wouldn't get the errors that only appear on database
> upgrade), you almost definitely have partial corruption.
> If it is partial corruption, it just means you'll need to use this fix:
> http://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding#Partial_vs_.22equal.22_corruption
> http://www.gossamer-threads.com/lists/mythtv/users/406111#406111

Thats exactly what I meant by the above paragraph - doing the partial
restore over a blank database, and it still didn't work....   any other
ideas?   I've currently moved back to 0.21, but gentoo is about to purge qt3
& friends from portage in the next few weeks so I'd really like to get it
upgraded cleanly.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100308/8a5c6caf/attachment.htm>

More information about the mythtv-users mailing list