[mythtv-users] Playstation 3 remote config: /etc/bluetooth/input.conf ignored?

Scott Alfter scott at alfter.us
Fri Mar 5 16:46:35 UTC 2010

Hash: SHA1

I've been trying to follow the directions here:


(referred from http://www.mythtv.org/wiki/Sony_PS3_BD_Remote)

The connection instructions don't appear to work, but I can get blueman-manager
to detect the remote, trust it, and connect to the input service.  The D-pad,
number keys, and a few others work, but xev shows no activity on several keys
(such as the four colored keys).  The XBMC wiki includes a keymap that appears
to map the colored keys to F7 through F10, so if it's working right, you'd
think that pressing "red" would turn up in xev as an F7 keypress (for
instance).  It still doesn't.

/etc/bluetooth/input.conf currently looks something like this (the map is
trimmed for brevity):

# Configuration file for the input service

# This section contains options which are not specific to any
# particular interface

# Set idle timeout (in minutes) before the connection will
# be disconnect (defaults to 0 for no timeout)

#[PS3 Remote Map]
# When the 'OverlayBuiltin' option is TRUE (the default), the keymap uses
# the built-in keymap as a starting point.  When FALSE, an empty keymap is
# the starting point.
OverlayBuiltin = FALSE
0x16 = KEY_E              # EJECT
0x64 = KEY_A              # AUDIO
0x65 = KEY_Z              # ANGLE
0x63 = KEY_T              # SUBTITLE
0x0f = KEY_DELETE         # CLEAR
0x28 = KEY_GRAVE          # TIMER
0x00 = KEY_1              # NUM-1
0x01 = KEY_2              # NUM-2
0x02 = KEY_3              # NUM-3
0x09 = KEY_0              # NUM-0
0x81 = KEY_F7             # RED
0x82 = KEY_F8             # GREEN
0x80 = KEY_F9             # BLUE
0x83 = KEY_F10            # YELLOW
0x70 = KEY_I              # DISPLAY
0x1a = KEY_S              # TOP MENU

At first, the "[PS3 Remote Map]" line was uncommented, but I tried to comment
it out as I don't know that there's anything in the other Bluetooth config
files that would pick up on it.  The MAC address is that of the remote; the
only other Bluetooth device I'm using is an Apple Wireless Keyboard, which
works properly, but I'd like to get the remote control working so I can use the
keyboard with my iPhone instead. :-) I can kinda-sorta control most MythTV
functions with the buttons that do work, but it'd be nice to have all of the
buttons working.

(Versions: media-tv/mythtv-0.22_p23069, net-wireless/bluez-4.39-r2,
net-wireless/blueman-1.10, sys-kernel/vanilla-sources-  As you
might've guessed from the previous, I'm using Gentoo.)

Scott Alfter
scott at alfter.us

Version: GnuPG v1.4.7 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the mythtv-users mailing list