[mythtv-users] .24 Audio results: mixed

Jean-Yves Avenard jyavenard at gmail.com
Tue Jun 29 01:46:44 UTC 2010


On 29 June 2010 11:21, Douglas Peale <Douglas_Peale at comcast.net> wrote:
> DTS and AC3 appeared appropriatly the first time I tried to mess with the setup after upgrading, now they no longer appear.
> Oddly, I just noticed that I am getting sound out of both the analog outputs and the SPDIF port simultaneously, even though I
> only selected analog 7.1.

Yeah, this can happen with some audio cards, and that's one of the
reason ALSA doesn't an API to report the type of output (e.g. analog
or digital).
Some of the cards are wired to both.

Pretty cool for you though...

I'm puzzled with your AC3/DTS non-appearance issue. I think it's
related to the settings Qt widget code.. I added some options allowing
me to do what I wanted (disappearing checkbox, changing the title of a
checkbox etc).

If you compiled your own version, it would help find out what's going
on as I could send you a version with extra verbose..

It's very easy to compile really... especially on ubuntu..

Open a terminal:
sudo apt-get build-dep mythtv

this will download all the dependency required...

Check out the source code:
svn co http://svn.mythtv.org/svn/trunk

to compile, go to the trunk/mythtv folder.
./configure --prefix=/location --compile-type=debug

replace /location with an area you have write access to (personally I
create  folder in /usr/local/mythtv-trunk, and make that folder
writeable by myself)

then you do
make -j2
make install

to run:
LD_LIBRARY_PATH=/location/lib /location/bin/mythtvfrontend -v audio

Alternatively, give me a login access to your machine, and I'll do it for you


More information about the mythtv-users mailing list