[mythtv-users] Mythbackend started as process looks for database at wrong location

John Nissley jnissley at nissley.org
Sun Jun 13 15:39:13 UTC 2010

I have a mythtv setup with two fe/be and two other fe only boxes.

I have a need to move the master backend from one backend server to the 
other but am having some problems doing so.

I have moved the database to the new server and shut down mysql on the 
old Master Backend server.  When I start the new  Master backend with 
"mythbackend &" it finds the new database server location correctly but 
when I try to start it with "service mythbackend start" it is still 
looking at the old database server location.  The logs tell me it is 
looking at /root/.mythtv for the config files and I have delete, copied, 
added the files to that location with the correct parameters multiple 
times but I still have the same result.  I have even run mythtv-setup as 
the mythtv and root user from the new Master Backend server but that 
still does not fix the problem.

I am using the init.d file from this location 
I have been using this file for many months without problem until I 
tried to move my Master Backend.

Master mythbackend log (My new database server is
2010-06-13 09:57:07.535 mythbackend version: trunk [25099] www.mythtv.org
2010-06-13 09:57:07.566 Using runtime prefix = /usr/local
2010-06-13 09:57:07.576 Using configuration directory = /root/.mythtv
2010-06-13 09:57:07.585 Using localhost value of family
2010-06-13 09:57:07.593 Testing network connectivity to ''
2010-06-13 09:57:07.616 New DB connection, total: 1
2010-06-13 09:57:07.618 Unable to connect to database!
2010-06-13 09:57:07.626 Driver error was [1/2003]:
QMYSQL: Unable to connect
Database error was:
Can't connect to MySQL server on '' (111)

2010-06-13 09:57:10.195 UPnPautoconf() - No UPnP backends found
2010-06-13 09:57:10.207 No UPnP backends found

No UPnP backends found

Would you like to configure the database connection now? [no]
[console is not interactive, using default 'no']
2010-06-13 09:57:10.257 Deleting UPnP client...
2010-06-13 09:57:10.905 Failed to init MythContext.

Keep in mind that config.xml and mysql.txt have both been changed to 
have the new database location of

Thanks for the assistance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100613/1c3040dd/attachment.htm>

More information about the mythtv-users mailing list