[mythtv-users] .23 Sound Issues............Please God shoot me now!!

Another Sillyname anothersname at googlemail.com
Wed Jun 2 05:45:55 UTC 2010

On 2 June 2010 06:37, Jean-Yves Avenard <jyavenard at gmail.com> wrote:
> Hi
> On 2 June 2010 14:57, Another Sillyname <anothersname at googlemail.com> wrote:
>> Thanks for the ideas.....I should have been a bit clearer about how I
>> was doing it before.
>> In my .22 setup I had added commands to .lircrc to allow the master
>> volume to be controlled using a combination of irexec commands via
>> pulseaudio, there is a specific lirc-pulseaudio module.
>> So in effect my .22 setup did this.
>> Mythtv --> Alsa Default --> Pulseaudio --> spdif out to Amp.
> There has been no fundamental change on the audio architecture between
> 0.22 and 0.23 except that if you are using a surround setup with
> digital audio, you know set it to 5.1 instead of stereo.
> So your configuration should be the same as it was before....
> If it broke, you modified something else and that's not in mythtv.
>> Did people have to tweak anything to get alsa default or pulseaudio
>> default working?
> pulse native support is broken in myth, less so than in 0.22 but it's
> still broken...
> when you start myth, if you are using ALSA output, the pulse server is
> suspended.
> If you don't want the pulse server to be suspended.
> Set the environment variable: DEBUG_PULSE_AUDIO_ALSA_EMULATION before
> starting mythfrontend
> this prevents myth from suspending pulse.
> You shouldn't have to change anything to have it working like it used to
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


That's very interesting, thanks for the tip.

More information about the mythtv-users mailing list