[mythtv-users] Pace RNG110 w/ Firewire

Ozzy Lash ozzy.lash at gmail.com
Sat Jul 31 02:42:11 UTC 2010

On Fri, Jul 30, 2010 at 5:46 PM, GZ <gzornetzer.lists at gmail.com> wrote:
> On Fri, Jul 30, 2010 at 1:44 PM, Jamin W. Collins
> <jcollins at asgardsrealm.net> wrote:
>> Has anyone had success using firewire with a Pace RNG110?  I've searched
>> the lists and seen a few posts[1] regarding it, but nothing really
>> indicating success.
>> So far, I can reliably (from the little testing I've done) change channels
>> using the 6200ch binary.  Like the referenced post, I can get mythprime to
>> succeed if I specify channel changer 1 or 2.
>> However, even when mythprime succeeds, both firewire_tester and test-mpeg2
>> fail.
>> I've tried two different systems, with two different firewire interfaces,
>> and two different firewire cables (one 6 pin, one 4 to 6 pin).
>> [1] - http://www.mythtv.org/pipermail/mythtv-users/2010-March/284056.html
> Hi Jamin,
> I have had a little bit of success getting firewire through the RNG110
> working.  The biggest problem for me was actually the firewire stack in the
> kernel.  I found that the older stack (on older versions of fedora) didn't
> allow recording.  However, updating to a more recent distribution (I think
> Fedora 11 or higher) did.  Can you try creating a live usb of the latest
> fedora to run test-mpeg2?  It worked for me and was a good testing platform
> .
> My only other problem was that there was a bug in the driver for a certain
> firewire chip (I think it was one of the TI chips) that caused random
> failures on x86-64.  I think it might be fixed in FC13.  As a result, I
> would recommend that you try the i386 version of the distribution to verify
> that things work and then slowly graduate to x86-64 (if desired) and mythtv.
> Good luck,
> -Greg

I must be really lucky.  I got one of these a few weeks ago while I
was setting up a new backend in the basement.  I did some basic
testing with the firewire tools, but myth 0.23 detected it with no
problems and it has been recording like mad for the last few weeks.  I
don't use it in Live TV though (I don't use myth for live tv).  I'm
running debian unstable with myth 0.23 from the debian-multimedia
repository.  I believe I did have to compile my own 6200ch from

One warning, at least on the one I have:

I plugged the ethernet interface into my network, thinking I might be
able to telnet to the box and perhaps have a way to change channels or
record over ethernet (the new box had firewire, but I had no firewire
cable).  I didn't see it get an address from my router or anything, so
I just assumed that the port was disabled, and forgot to unplug it.
The next day, the family started complaining that their windows boxes
couldn't connect to the internet.  When I got home and checked it out,
I found out that the box was giving out dhcp leases on a different
subnet. (I think it was 192.168.100.x)


More information about the mythtv-users mailing list