[mythtv-users] Permission problem on /dev/video 0-3

MacNean Tyrrell dardack at gmail.com
Sat Jul 31 02:27:23 UTC 2010

On Fri, Jul 30, 2010 at 12:07 PM, <mythtv.t.wuuza at xoxy.net> wrote:

> > /usr/bin/service mythtv-backend restart
> > But it still doesn't fix it. However, once X is loaded if i run same
> > command it's fine.
> Here's the script I use to delay until the udev permissions are set on my
> tuner (ie group is video instead of root).  I post this because A) it
> might help you and B) if anyone has a better way of doing this I'm
> listening.  I'm a programmer but not a bash expert.  It seems like this
> should be possible without a temp file but I couldn't get it to work and
> it was getting late the night I was messing with it.  I'm sure there are
> other ways to check permissions, too.
> #!/bin/sh
> while true; do
>        find /dev/video1 -group video > /tmp/waitForVideo
>        if [ `grep video1 /tmp/waitForVideo` ]; then
>                break
>        fi
>        sleep 1
> done
You stick the command for the script in your rc.local?

Just real quick (i left my program days 12 years ago for accounting/computer
forensics, so bare with me) I know the find command, what does the -group
video do?  I mean I get that it's putting whatever the find command finds
into /tmp/wfv and then if there is an entry for video1 breaking, just don't
understand the -group video option.

> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


MacNean C. Tyrrell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100730/2c03d8c7/attachment.htm>

More information about the mythtv-users mailing list