[mythtv-users] Permission problem on /dev/video 0-3

MacNean Tyrrell dardack at gmail.com
Fri Jul 30 00:49:17 UTC 2010

On Thu, Jul 29, 2010 at 7:44 PM, Nick Rout <nick.rout at gmail.com> wrote:

> On Fri, Jul 30, 2010 at 6:01 AM,  <mythtv.t.wuuza at xoxy.net> wrote:
> >> Is there a way to do this in rc.local, i have a loop on my laptop to
> > wait
> >> until iwconfig has an ip address and then mount -a, because samba was
> > not
> >> mounting my shares correctly because the wireless took so long to get an
> > ip
> >> address. So would love a way to wait for mythbackend to start, or
> > restart
> >> mythbackend once mythfrontend is running.
> >
> > I don't know.  I'm not all that familiar with this stuff, especially
> since
> > things have been changing recently (like upstart).  If he's got a default
> > Mythbuntu install then mythtv-backend is an upstart job.  You could write
> > another upstart job that does the checking loop, and then modify the
> > mythtv-backend job to depend on that one (ie add it to "start on"
> stanza).
> >  Writing the upstart job is easy - I have one in there that calls the
> same
> > firewire primer script as my sleep/resume script does.  In Kubuntu 8.04
> > there was an issue where the backend started before networking was fully
> > loaded and it never found my HDHomeRun.  For that I just took the easy
> > route and put a "sleep 10" in the backend init script, so that would be
> > another easy option.
> I suspect the backend is starting before the pvr module is loaded, and
> the permission denied message is because the device nodes simply are
> not there.
> Add a delay to the backend startup script, or restart the backend in
> /etc/rc.local.
> That's the thing i did.  I have:

/usr/bin/service mythtv-backend restart

But it still doesn't fix it.  However, once X is loaded if i run same
command it's fine.

> Supposedly upstart should be able to create a situation where it says
> "start the backend after the following modules have loaded" - but the
> mythbuntu engineers do not seem to be able to get it to work like
> that. (of course everyone has different "modules" that need to  load
> first)
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


MacNean C. Tyrrell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100729/fb4f254c/attachment.htm>

More information about the mythtv-users mailing list