[mythtv-users] Streaming MythTV recordings (MPEG-2) to an Xbox 360

Calvin Harrigan charriglists at bellsouth.net
Wed Jul 28 14:06:27 UTC 2010


On 7/27/2010 4:28 PM, Jay Foster wrote:
>  > On 22 July 2010 16:21, Greg <greg12866 [at] nycap
>  > <mailto:greg12866 [at] nycap>> wrote:
>  >
>  > On 07/22/2010 05:08 AM, Vitani wrote:
>  >> Good morning,
>  >>
>  >> For over a year I've been happily streaming my MythTV recordings
>  >> from my Mythbuntu server to an Xbox "classic" which was running
>  >> XBMC. I did this by setting up symbolic links with "pretty" names
>  >> in a nicely organised TV folder directly to the MPEG-2 files in
>  >> the MythTV recording folder.
>  >>
>  >> Now times have moved on a bit and I've "acquired" some HD content
>  >> which I'd like to view on my TV as opposed to my PC, or by
>  >> connecting my netbook to the TV so I bought myself a broken 360
>  >> (the DVD drive doesn't work, but that's another story) with the
>  >> intention of swapping one Xbox for another.
>  >>
>  >> I did my research before-hand and found out that the 360 does
>  >> play MPEG-2, but I have since found out that it only does that
>  >> through Windows Media Centre, not using uPnP/DLNA. Obviously as
>  >> I'm using MythTV installing Windows on my server wasn't really an
>  >> option, but a friend suggested running it in a VM. I tried this,
>  >> and it worked (using a mapped drive from the Windows VM to a
>  >> samba share on the host machine), but it was unusabley slow
>  >> taking about a minute to become responsive after start up and
>  >> then taking up to 30 seconds to respond to the OK button.
>  >>
>  >> So, my question today is has anyone done this and got it working?
>  >> Do you have any advice? Are there options I haven't considered
>  >> (which wont cost me more, the Mrs is already annoyed that I've
>  >> spent 75 and she can't watch Eastenders atm)? Is there someway I
>  >> could transcode these videos on the fly into another format the
>  >> Xbox 360 supports? Shall I just cut my losses and revert back to
>  >> the Xbox Classic with XBMC and miss out on HD?
>  >>
>  >> Cheers!
>  >>
>  >>
>  >> _______________________________________________
>  >> mythtv-users mailing list
>  >> mythtv-users [at] mythtv <mailto:mythtv-users [at] mythtv>
>  >> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>  >>
>  > I use the PS3 media server..It also works on the xbox360... It
>  > transcodes on the fly...
>  >
>  > http://ps3mediaserver.org It works in Linux and windows.
>  >
>  >
>  > Just installed PS3 Media Server (there's a nice deb package for Ubuntu
>  > at http://ps3mediaserver.org/forum/viewtopic.php?f=3&t=5589
>  > <http://ps3mediaserver.org/forum/viewtopic.php?f=3&t=5589> which make
>  > it a piece of cake to install) and oh wow - it just works. Not only
>  > does it just work, but I can play ISOs (although not with the menus)
>  > and videos in archive files too! Playing DVD ISOs on a 360, wow! I
>  > didn't think it was even possible :oD
>  >
>  > Thanks for the great tip Greg!
>  >
>  >
>  > _______________________________________________
>  > mythtv-users mailing list
>  > mythtv-users [at] mythtv
>  > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>  >
> I have installed the PS3 Media Server on my mythbuntu 8.10 (0.21-fixes)
> machine and I am trying to use it with a Sony TV that does UPnP/DLNA. I
> can get it to play ISOs and my recordings that I archived into
> mythvideo. When I try to play recordings from Myth's recording
> directory, it either fails or displays garbage on the screen. However,
> if I first perform a lossless transcode on the recording file it will
> play perfectly (this is how I made the recording archives in the
> mythvideo directory). These are HDHR ATSC MPEG2 recordings. Is there
> something funky about these that won't play directly to a Sony TV? What
> exactly might a lossless transcode be doing that makes the files play?
>
> I do have an XBOX360, but I haven't had time to try that out yet.
>
> Jay
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
I've had a similar problem with recordings since the upgrade to 0.22. 
 From what I can tell/remember it has to do with the type of mpeg2  myth 
now records.  Myth does ts type encoding as opposed to ps.  Transport 
stream is what you typically get from OTA digital channels.  Most 
players are designed to play ps type mpeg2 files program stream.  I 
think one of the major differences is that ps files have a header that 
describes what is to follow while the ts doesn't as you can start 
watching it at any point during the broadcast.  Transcoding pretty much 
converts the ts to a ps mpeg file so it works afterwords.  I haven't 
spent much time trying to fix work around this been too busy, perhaps 
someone has found a solution?


More information about the mythtv-users mailing list