[mythtv-users] Slightly OT - re-building an atrpms package

Ken Smith kens at kensnet.org
Wed Jul 28 09:56:17 UTC 2010

Ken Smith wrote:
> Ken Smith wrote:
>> Jarod Wilson wrote:
>>> On Fri, Jul 23, 2010 at 7:10 PM, Jarod Wilson <jarod at wilsonet.com> 
>>> wrote:
>>>> On Fri, Jul 23, 2010 at 5:07 PM, Ken Smith <kens at kensnet.org> wrote:
>>>>> Hi, Slightly off topic, but I wonder if someone here can advise 
>>>>> me. I need to build a ivtv rpm for
>>>>> kernel-2.6.18-194.8.1.el5.centos.plus as its not on atrpms (yet) 
>>>>> When I run the rpm build I get
>>>>> error: line 3: Unknown tag: %kmdl ivtv
>>>>> I have brewed up a few rpm's previously but I'm by no means an 
>>>>> expert. So I'd appreciate some advice.
>>>> {snip}
>> Thanks Jarod, The helper package worked and I have put the packages I 
>> built here -> www.kensnet.org/atrpms
>> I tried using the earlier ivtv.ko but I got some symbol fails. 
>> Interestingly I copied the earlier nVidia driver file in the same way 
>> and it worked fine.
>> Before I got the rpmbuild working I tried a make / make install of 
>> the ivtv tar.gz that was in the source rpm. It seemed to work and I 
>> could cat /dev/video0 and get a reasonable .mpg file, but myth wasn't 
>> interested in working the pvr350. But after I got the v4l rpm built 
>> and installed myth was happy. Maybe I should have moved some other 
>> v4l bits over from the previous kernel
>> and it might have worked.
>> Thanks
>> Ken
> I spoke too soon - The system I'm working with is intended to have a 
> PVR350 (ivtv) and a pair of Nova-T's DVB (cx88) and hopefully at some 
> future date a DVB-S card.
> I'm on kernel  2.6.18-194.8.1.el5.centos.plus, which includes the cx88 
> driver. The previous kernel,  2.6.18-194.3.1.el5.centos.plus, 
> accidentally had the cx88 driver missing.
> If I load the ivtv driver rpm that I built, based on atrpm's sources, 
> for 2.6.18-194.8.1.el5.centos.plus and then load the video4linux rpm I 
> built the video4linux one de-installs the ivtv one in the process of 
> installing but I get the PVR 350 working in Myth
> {snip}

Update on this. Some research pointed me to a conflict between the cx88 
modules that come with kernel-2.6.18-194.8.1.el5.centos.plus and the 
ones in the video4linux package. I manually removed the kernel supplied 
ones and its now working.

:-) Ken

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the mythtv-users mailing list