[mythtv-users] MythWeb shared memory cache

Phil Linttell phil.linttell at rogers.com
Tue Jul 27 20:19:11 UTC 2010

> Date: Fri, 23 Jul 2010 20:57:33 -0400
> From: "MarcT" <myrdhn at gmail.com>
> Subject: Re: [mythtv-users] MythWeb shared memory cache
> -----Original Message-----
> Sent: Friday, July 23, 2010 8:08 PM
> To: mythtv-users at mythtv.org
> Subject: [mythtv-users] MythWeb shared memory cache
> I was changing settings within mythweb (trunk), and tried turning on the 
> "use linux shared memory cache" (or similar wording).  Now, after 
> logging into mythweb, I get the following message:
> *    Warning* at /var/www/html/classes/Cache/SHM.php, line 29:
>      shm_get_var(): variable key 1 doesn't exist
> and I can't get past it.
> I can't seem to find any information on how to configure a shared memory 
> cache, or how to turn off the setting in mythweb now that I've broken 
> it.  I've tried re-installing mythweb, but I'm guessing the setting was 
> changed in the database somewhere.
> Any suggestions of how I can get mythweb working again?
> Thanks,
> Phil
> _______________________________________________
> I'm not finding any place for a shared cache setting. I did find an "Enable
> a cache engine?" field, but the only option I have is default.
> You could try to search SQL directly by: 
> select * from settings where value like '%cache%';
> MarcT
Thanks for the tip, Mark.  I couldn't find anything obvious in the
settings table, however, using the MySQL Query Browser, I tried to find
any other tables that seemed mythweb related...

In the "mythweb_sessions" table I found a row that corresponded to my
user ID.  I deleted the row, and now I can login to mythweb again.

The setting that got me into trouble in mythweb in the first place was:

Settings->MythWeb->MythWeb Defaults->Enable a cache engine?->Unix Shared

I won't be choosing that setting again!


More information about the mythtv-users mailing list