[mythtv-users] MythWeb shared memory cache

MarcT myrdhn at gmail.com
Sat Jul 24 00:57:33 UTC 2010

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Phil Linttell
Sent: Friday, July 23, 2010 8:08 PM
To: mythtv-users at mythtv.org
Subject: [mythtv-users] MythWeb shared memory cache

I was changing settings within mythweb (trunk), and tried turning on the 
"use linux shared memory cache" (or similar wording).  Now, after 
logging into mythweb, I get the following message:

*    Warning* at /var/www/html/classes/Cache/SHM.php, line 29:
     shm_get_var(): variable key 1 doesn't exist

and I can't get past it.

I can't seem to find any information on how to configure a shared memory 
cache, or how to turn off the setting in mythweb now that I've broken 
it.  I've tried re-installing mythweb, but I'm guessing the setting was 
changed in the database somewhere.

Any suggestions of how I can get mythweb working again?



I'm not finding any place for a shared cache setting. I did find an "Enable
a cache engine?" field, but the only option I have is default.

You could try to search SQL directly by: 
select * from settings where value like '%cache%';


More information about the mythtv-users mailing list