[mythtv-users] SPDIF surround broken in trunk

Jean-Yves Avenard jyavenard at gmail.com
Sat Jul 17 17:26:04 UTC 2010


On Saturday, July 17, 2010, Greg Woods <greg at gregandeva.net> wrote:
> On Sun, 2010-07-18 at 01:34 +1000, Jean-Yves Avenard wrote:
> \
>> Starting to help would be to actually describe what issue you're
>> having instead a very long version of "it doesn't work"
> I have already done this; there has been a long thread. I have posted
> screenshots.

That can't be. You posted screen shots before I changed the logic in
detecting if a device is digital or not.

While ALSA reports in the description of the device that its analog,
it would now still be reported as digital just because the name is

>> > If there is anything else I can do to help troubleshoot my problem or if
>> > anyone else has seen surround sound break in recent updates, please let
>> > me know. I cannot completely rule out something I may have messed up
>> > with settings or the database, but the bottom line is that surround
>> > sound was working, I did an svn up and recompiled, and now surround
>> > sound is not working. I don't know how else to get it working other than
>> > going back to a previous version where it worked. I suppose it will be
>> > interesting to see whether or not this is successful.
>> Did you update to the version I mentioned earlier, that should fix the
>> AC3 and DTS flag not showing up with your card?
> Yes, I am currently running 25339, more recent than the 25334 you
> recommended. These are the screenshots that I posted.

See above.

You're still not seeing the changes and ac3 and DTS still don't show?

>> You will not get surround sound unless AC3 and/or DTS box are checked
>> with SPDIF output.
> OK, so it sounds like my problem is that I'm not seeing those
> checkboxes, so presumably it doesn't think any of my output devices are
> digital?

That would be the problem yes.
The name contains analog. Which usually is a pretty good hint that a
device is analog and not digital :)

>> what does aplay -L and aplay -l shows on your box.
> Bizarre. -L shows none of the devices are digital, even the IEC958 shows
> as analog despite having "digital" in the description. -l shows that
> there is a digital output. But I haven't updated anything other than
> Myth on this box in many moons; it is still running Fedora 10. What
> should I look for in alsamixer in case I have messed something up trying
> to get this to work? I checked for the obvious and the IEC958 device is
> not muted but the IEC958 loop is. These show up as "S/PDIF" and "S/PDIF
> L" in the terminal version of alsmixer. There is also a slider labeled
> "Digital" which is not muted.
Unfortunately, myth can only make assumptions based on what alas
reports, and it reports analog :(

I'm going to send you a patch a tad more verbose with the logs, that
will help diagnosing what's going on.

>> When you select ALSA:iec958 in the list, you should have 3 checkboxes
>> showing up, the first one is visible but disabled, the 2nd one is AC3
> Right, but as shown in the screenshots, there are no checkboxes.
> [root at confusion trunk]# aplay -L
> default:CARD=CMI8788
>     C-Media CMI8788, Analog
>     Default Audio Device
> front:CARD=CMI8788,DEV=0
>     C-Media CMI8788, Analog
>     Front speakers
> surround40:CARD=CMI8788,DEV=0
>     C-Media CMI8788, Analog
>     4.0 Surround output to Front and Rear speakers
> surround41:CARD=CMI8788,DEV=0
>     C-Media CMI8788, Analog
>     4.1 Surround output to Front, Rear and Subwoofer speakers
> surround50:CARD=CMI8788,DEV=0
>     C-Media CMI8788, Analog
>     5.0 Surround output to Front, Center and Rear speakers
> surround51:CARD=CMI8788,DEV=0
>     C-Media CMI8788, Analog
>     5.1 Surround output to Front, Center, Rear and Subwoofer speakers
> surround71:CARD=CMI8788,DEV=0
>     C-Media CMI8788, Analog
>     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
> iec958:CARD=CMI8788,DEV=0
>     C-Media CMI8788, Analog
>     IEC958 (S/PDIF) Digital Audio Output
> null
>     Discard all samples (playback) or generate zero samples (capture)
> [root at confusion trunk]# aplay -l
> **** List of PLAYBACK Hardware Devices ****
> card 0: CMI8788 [C-Media CMI8788], device 0: Analog [Analog]
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> card 0: CMI8788 [C-Media CMI8788], device 1: Digital [Digital]
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0

With that info, Ill simulate what's going on and try to find a work around.

>> What's the resolution of your screen?
> I believe the physical TV pixels are actually 1024x768, however the TV
> can and does accept HD input. The TV says that the input signal is
> 1920x1080 (either from HDMI on the computer or directly from the cable
> STB), so that is what X is generating.

Ok. I set my pc to use 1024x768 and still the capabilities box is
never that small. Which theme are you using?

More information about the mythtv-users mailing list