[mythtv-users] Problems with rebuilt seek table

John Pilkington J.Pilk at tesco.net
Mon Jul 12 07:18:12 UTC 2010

On 12/07/10 07:41, Rob Verduijn wrote:
> I feel your pain
> I'm currently watching tv without the use of cutlists.
> Check out :
> http://svn.mythtv.org/trac/ticket/7978
> and possibly,
> http://svn.mythtv.org/trac/ticket/5963
> It looks like they are intending to fix this with the 0.24 release.
> Until then you could try these tricks, although they no longer work for me :(
> Try cleaning up your db with the maintenance scripts.
> * flush_deleted_recgroup.pl
> * myth.find_orphans.pl
> * optimize_mythdb.pl
> Or
> Rebuild your seektable with 'mythcommflag --rebuild'
> Or  (adjust values for your own files)
> mythtranscode --mpeg2 --buildindex --showprogress --chanid 1014
> --starttime 20100609234500
> If you find any other tricks let me know.....I hate watching
> recordings without cutlists
> Rob
> 2010/7/12 Christopher Meredith<chmeredith at gmail.com>:
>> I've been using a script which converts HD-PVR recordings to mpeg2/ac3
>> then rebuilds the seektable so I can take advantage of Myth features
>> such as transcoding with cutlists and such. It has been working fine
>> but has become one of the casualties of a recent update to current
>> trunk. Here's what I do:
>> Convert the recording with this command:
>> ffmpeg -i input.mpg -vcodec mpeg2video -pix_fmt yuv420p -threads 4
>> -qscale 1 -b 19000k -acodec ac3 -ab 192k -ac 2 -async 1 -y -f vob
>> output.mpg
>> Then I move output.mpg to input.mpg and run this:
>> mythtranscode --mpeg2 --buildindex --allkeys --showprogress --infile input.mpg

I'm not sure what --allkeys is supposed to do in this context.  I 
suppose that in a 'proper' transcode it produces a file that is entirely 
composed of I frames (ie it treats every frame independently so that the 
result is larger than a normally coded mpeg2 file but can be more 
accurately edited), but here you are just cataloguing the existing 
keyframes.  What happens if you leave it out?  And IIRC there's 
sometimes a difference between the --infile treatment and the --chanid 
--starttime treatment.  HTH.

John P

>> As I said, this has worked fine in the past. Now, however, the time
>> seems to be "stretched." I can fast forward to the end of the
>> recording time-wise, but there is still video after that point.
>> Cutpoints work for playback but not transcoding. In short, it's a bit
>> of a mess.
>> My only theory is that since the HD-PVR records at 60fps and since the
>> converted mpeg2 file is also at 60fps, this is throwing off
>> mythtranscode and the seek table rebuild. Don't know why it worked
>> previously but not now, but can anyone shed some light on this?
>> TIA!

More information about the mythtv-users mailing list