[mythtv-users] Problems with rebuilt seek table

Christopher Meredith chmeredith at gmail.com
Mon Jul 12 05:08:17 UTC 2010

I've been using a script which converts HD-PVR recordings to mpeg2/ac3
then rebuilds the seektable so I can take advantage of Myth features
such as transcoding with cutlists and such. It has been working fine
but has become one of the casualties of a recent update to current
trunk. Here's what I do:

Convert the recording with this command:
ffmpeg -i input.mpg -vcodec mpeg2video -pix_fmt yuv420p -threads 4
-qscale 1 -b 19000k -acodec ac3 -ab 192k -ac 2 -async 1 -y -f vob

Then I move output.mpg to input.mpg and run this:
mythtranscode --mpeg2 --buildindex --allkeys --showprogress --infile input.mpg

As I said, this has worked fine in the past. Now, however, the time
seems to be "stretched." I can fast forward to the end of the
recording time-wise, but there is still video after that point.
Cutpoints work for playback but not transcoding. In short, it's a bit
of a mess.

My only theory is that since the HD-PVR records at 60fps and since the
converted mpeg2 file is also at 60fps, this is throwing off
mythtranscode and the seek table rebuild. Don't know why it worked
previously but not now, but can anyone shed some light on this?


More information about the mythtv-users mailing list