[mythtv-users] Last commercial break during recording

Tony Lill ajlill at ajlc.waterloo.on.ca
Thu Jan 21 04:19:39 UTC 2010

Rod Smith <mythtv at rodsbooks.com> writes:

> On Friday 15 January 2010 11:34:01 am Aaron wrote:
>> I'm not sure if this is a bug or "as designed"; but when recording a
>> show and having it skip commercials, MythTV always misses the very
>> last commercial break. Is this so you don't miss the preview for next
>> week's show?
> AFAIK, it's not a design feature. Two possible causes spring to mind:
> 2) Sometimes, when commflagging while recording, the commflagging
>    process terminates before the recording has finished. This seems
>    most common for me when it's a remote backend doing the commflagging.
>    The result is that the last commercial break (or two or three or
>    more) will be unflagged. The solution is to run commflagging after
>    the show has completely recorded. Since I often want to start
>    watching while the show is still recording, I've left my system
>    configured to start commflagging when the recording starts, but I
>    also check the status page and if I notice anything with suspiciously
>    few commercial breaks found, I go in and tell Myth to re-flag that
>    recording. There may be a relatively simple solution to this problem
>    (adjusting NFS mount options, for instance), but if so I don't know
>    what it is.

What about when transcoding finishes before commflagging, and swaps
the file before the commflagger gets to the end?

Tony Lill,                         Tony.Lill at AJLC.Waterloo.ON.CA
President, A. J. Lill Consultants                 (519) 650 0660
539 Grand Valley Dr., Cambridge, Ont. N3H 2S2     (519) 241 2461
--------------- http://www.ajlc.waterloo.on.ca/ ----------------

More information about the mythtv-users mailing list