[mythtv-users] frontend hardware - any reason not to use ion?

Greg Oliver oliver.greg at gmail.com
Mon Jan 11 18:22:17 UTC 2010

On Mon, Jan 11, 2010 at 11:42 AM, Kirk Bocek <t004 at kbocek.com> wrote:
> Johnny Walker wrote:
>> Sounds good - I'll look into that at home later.
>> Why does my Xorg.0.log show this:
>> (II) NVIDIA(0): NVIDIA GPU ION LE (C79) at PCI:3:0:0 (GPU-0)
>> (--) NVIDIA(0): Memory: 524288 kBytes
>> The BIOS only let me set the video aperture size to 256.
> My understanding of video aperture is that it is a window used by the video
> card to access main memory. It is not directly related to the amount of memory
> on the card. I've generally ignored the setting when configuring a new host
> and have never had problems.
> But you reminded me to check *my* Xorg log for memory settings:
> (II) Jan 06 23:28:37 NVIDIA(0): NVIDIA GPU ION LE (C79) at PCI:3:0:0 (GPU-0)
> (--) Jan 06 23:28:37 NVIDIA(0): Memory: 524288 kBytes
> (--) Jan 06 23:28:37 NVIDIA(0): VideoBIOS: 62.79.6c.00.01
> So comparing that to my previous 'free' output, I'd say that the video memory
> allocation is dynamic. I think the Nvidia driver will take whatever memory it
> needs up to the reported 512MB.

Yes, the nvidia driver reports 512 no matter what..  Important thing
to note, is that with 2.6.31+ kernels, you must have 512 for vdpau to
work properly..  Once I got 512 on mine, all of my HD recording
started working perfectly.  You can back down to <= 2.6.30 for 256
cdpau to operate though..  An nvidia engineer confirmed this in a
thread on nvnews a while back..


More information about the mythtv-users mailing list