[mythtv-users] Zotac IONITX-B-E Network Issues

Frank Merrill fmerrill1 at gmail.com
Sun Jan 10 19:13:52 UTC 2010

On Sun, Jan 10, 2010 at 1:56 PM, Greg Grotsky <spikeygg at gmail.com> wrote:
> Thanks for the response Frank.  I actually downloaded and played with
> ethtool during my troubleshooting before RMA'ing the board.  It was set to
> full-duplex and I tried to use ethtool to adjust the settings but for some
> reason it wouldn't let me change anything.  I tried forcing to half-duplex,
> I tried turning autoneg off, and I tried forcing to 100mbps or even 10mbps,
> every time it told me that it could not set the values.  Oh well, we'll just
> have to see what the new board brings.

I didn't see where it might have been stated what distribution you are
running, but:
ethtool -s eth0 duplex half
would fail on a *buntu system for a few reasons.
First, you'd need to use 'sudo' and second, you have to turn off
auto-negotiation first.
So, on an *buntu dist, you'd do something like:

sudo ethtool -s eth0 autoneg off
sudo ethtool -s eth0 duplex half
and then
sudo ethtool eth0
to display the results

In any case, hopefully none of that will be necessary for the new board.


More information about the mythtv-users mailing list