[mythtv-users] mencoder, x264, and myth

Yan Seiner yan at seiner.com
Sat Jan 9 17:51:22 UTC 2010

jedi wrote:
> On Sat, Jan 09, 2010 at 08:48:57AM -0800, Yan Seiner wrote:
>> Is anyone using mencoder to create h.264 videos for myth?
>> If so, would you please share your mencoder -ovc x264 -x264encopts?
>> I've been struggling with this all morning; I can't get mencoder to
>> produce anything useful using x264.  It either tells me it can't
>> initialize, or the resulting video is unplayable.
>> -lavc works fine, so I expect it's my newbish efforts at h.264 that
>> are the problem.
> ...what distro are you running? I have been having trouble with the latter
> Ubuntus and x264 in mencoder. OTOH, I have been using some x264 for my vids
> for a long time...
Debian, but I'm running svn mplayer.

>    I do 2 passes I I just "copy" the audio. I don't bother converting it.
>    Here's my x264 options. The bitrate I use is 1500.
> X264_PASS1="-ovc x264 -x264encopts subq=4:bframes=4:b_pyramid:weight_b:pass=1:psnr:bitrate=$BITRATE:turbo=1"
> X264_PASS2="-ovc x264 -x264encopts subq=5:partitions=4x4:8x8dct:frameref=3:me=hex:bframes=4:b_pyramid:pass=2:psnr:bitrate=$BITRATE" 

Thanks!  That at least seems to work - almost.  For some reason, the 
b_pyramid causes mine to fail, but it's running without it.  I also 
added threads-auto as I have a dual core system.



   ,>/'_         o__
   (_)\(_)       ,>/'_          o__
A day may come  (_)\(_)         ,>/'_      o__
when the courage of men fails, (_)\(_)     ,>/'_ 
when we forsake our friends and break all (_)\(_)
bonds of fellowship, but it is not this day.
It is not this day!
This day we ride!

More information about the mythtv-users mailing list