[mythtv-users] No DTS with Internal Player

James Oltman cnlibmyth at gmail.com
Fri Jan 8 00:46:37 UTC 2010

On Thu, Jan 7, 2010 at 5:06 PM, Steven Adeff <adeffs.mythtv at gmail.com>wrote:

> On Thu, Jan 7, 2010 at 10:03 AM, James Oltman <cnlibmyth at gmail.com> wrote:
> > I have several MKV files and M2TS files that have DTS audio streams.
> > MPlayer plays these files fine with DTS.  However, Internal doesn't.  All
> I
> > get is Dolby Digital 5.1.  In the Audio Settings page I have tried
> different
> > combinations.  I've tried with both DD and DTS checked.  I've tried with
> DD
> > checked and not DTS and vice versa.  Also tried with nothing checked and
> got
> > simple stereo (not digital).  I have no Advanced Audio settings checked.
> > What am I doing wrong?  Thanks!
> >
> > Jim
> try disabling the DTS passthrough but keep AC3 passthrough enabled.
> Don't ask me why but it works on my two frontends, one connected via
> HDMI and the other via SPDIF.

I have already tried this.  The only way I was able to get DTS audio was to
uncheck the "Use Internal Volume Controls".  However, this had the
unfortunate side effect of making the video move in slow motion.  The audio
would register as DTS, but I heard no sound and the DTS light on my receiver
was cutting in and out.  With Internal Volume Controls unchecked, I tried
the "Advanced Audio Configuration" and it didn't do any good.  Any
combination that includes unchecking Use Internal Volume Controls results in
slow video and no sound.  I'm using a Creative 5.1 Gamer edition with SPDIF
coax out.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100107/5437cb7f/attachment.htm>

More information about the mythtv-users mailing list