[mythtv-users] Jerky playback with ITV HD

T D topper.doggle at googlemail.com
Sun Jan 3 15:04:14 UTC 2010

I'm running 0.22-fixes.  I have two boxes, each running a frontend and
backend.  One backend contains a DVB-S card which is pointed at 22.2E
for Astra and Eurobird (in particular "Freesat" services here in the
UK).  My CPU is an Athlon 64 X2  6000+, and I have an Geforce 8300
(the onboard version of the 8200) connected via HDMI.

The main reason for having the DVB-S is that DVB-T in the UK doesn't
yet support HD, and I want to watch BBC HD and ITV HD.  Things mostly
work well, but ITV HD is flaky.  I've finally managed to tune it in,
but it's sometimes rather jerky.  My system is currently set to use
VDPAU Slim.  Also, I should say that BBC HD is problem-free on this

So, with -v playback on ITV HD, I notice lots of:
2010-01-03 14:28:10.285 Set video sync frame interval to 40000
2010-01-03 14:28:10.285 Enabled deinterlacing
2010-01-03 14:28:10.320 Set video sync frame interval to 40000
2010-01-03 14:28:10.320 Enabled deinterlacing
2010-01-03 14:28:10.352 Set video sync frame interval to 40000
2010-01-03 14:28:10.385 Enabled deinterlacing

I'm not sure what this means, but I don't see why it's happening 20-30
times a second.  I am guessing that anything occuring this often could
be enough to make the ITV HD playback jerky, but I don't know what to
do about it.  For what it's worth, I tried changing from VDPAU Slim to
(non-VDPAU) Normal, and the jerkiness went, but there was a blurriness
instead, CPU utilization was up to 90%, and the "Set video sync frame
interval to 40000" messages vanished although the "Enabled
deinterlacing" was still present.

Can anyone provide advice on how I should debug this further?


More information about the mythtv-users mailing list