[mythtv-users] MythWeb doesn't work since upgrade to 0.22 - 'Incompatible protocol version'

Phillip Barnett phillip.p.barnett at gmail.com
Tue Feb 23 13:11:19 UTC 2010

I was running 0.21 on Mythbuntu, and upgraded by compiling the latest  
0.22 SVN. Since I'd missed a few dependencies, the upgrade didn't work  
(details not important, forgot to install libxv package so no compiled  
VideoOutput)-  when I'd eventually struggled through what was missing,  
and tried a few days older version, I eventually settled for the  
stable 0.22 tarballs release, whgich I've now got (mostly) working.  
(Have to run Mythfrontend by hand  - the Xsession keeps closing before  
it's opened, but that's something to address later)

Anyway, the last major problem is that Mythweb won't work - I get  
complaints of the database schema being incorrect.

'Error at /usr/share/mythtv/mythweb/includes/mythbackend.php, line 172:
Incompatible protocol version (mythweb=40, backend=50)'

I downloaded the 0.22 plugins official tarball and compiled and  
installed that, but it made no difference - same error message.

The database was upgraded automatically a couple of times when I ran  
the different Mythfrontend svn versions - have I upgraded too far for  
the 0.22 official release and now need to correct this, or should I  
try once again to get the SVN version compiled and installed, or have  
I missed something obvious?

Thanks in advance for any help.


More information about the mythtv-users mailing list