[mythtv-users] cut HD-PVR content with audio/video sync issues

Greg Oliver oliver.greg at gmail.com
Fri Feb 19 03:49:11 UTC 2010

On Thu, Feb 18, 2010 at 9:42 PM, Nick Rout <nick.rout at gmail.com> wrote:
> On Fri, Feb 19, 2010 at 12:16 PM, Doug Vaughan <r.d.vaughan at rogers.com> wrote:
>> I have not tried Robert's script in a very, very long time. The only reason
>> is that I do not trust the automated process to decide where the cuts should
>> be and you cannot adjust the edits in a Avidemux project file at least with
>> v2.4.x this may have changed in v2.5.x.
>> As for Avidemux v2.5.x, just last week I tried Ubuntu's v2.5.1 deb, a v2.5.2
>> deb and compiled 2.5.2 version from the Avidemux svn. All aborted trying to
>> open a HDPVR mpg/AC3 recording. I posted the abort on the Avidemux forum but
>> did not get a response. I would like to upgrade but right now I am sticking
>> to my compiled version from late last November.
>> I used to sometimes get audio out of sync. If the out of sync was consistent
>> throughout the file I used mkvmerge GUI to make adjustments. Out of sync
>> audio that happened somewhere after the beginning of the loss-less video was
>> usually a reflection of some transmission error recorded on the original
>> HDPVR mpg file.
>> When I first got my HDPVR I could not channel change my STB so I recorded on
>> a STB/PVR before using the HDPVR. Every time I had an HDPVR recoding issue I
>> could trace it back to the source. One movie I recorded multiple times from
>> my Cable company and it always had the same picture and sound errors in the
>> same time locations.
>> Over the last 12 months or so there has been both firm ware upgrades but
>> also a number of improvements on the Linux side (driver and MythTV). So I
>> rarely see audio out of sync any more.
>> I may give Roberts script another shot and adjust the commercial cuts within
>> MythTV itself. I just had gotten very used to the manual process.
>> I thought I read that your audio goes out of sync gradually. If true then
>> try an experiment.
>> 1) Use the script's avidemux project file but change the output container to
>> be avi rather than mkv
>> 2) Then process the resulting avi file through ffmpeg or mkvmerge to see if
>> the final mkv file maintains audio sync.
> I read a thread on the mythbuntu forum during this week that was about
> hdpvr audio sync. Here is what was written in conclusion:
> "The audio delay actually gets worse as time goes on. At the
> beginning, it seems ok and then after a few minutes, you start to
> notice a change...or drift. So, using that key word, I searched around
> and found some people were also referring to this as "drift". Using
> the right word makes all the difference in your searching.
> People were noticing that the video was recording at 60fps rather than
> 59.94 (like the audio). Sure enough, so was mine. Using MediaInfo, I
> was able to easily confirm this.
> I had installed the most recent driver/firmware (in windows).
> Hauppauge calls it a driver, but it is actually both. This was
> supposed to fix the problem, but obviously had not. I called Hauppauge
> to inquire about it. I asked if there was a way to confirm that the
> firmware actually "took". They said no. How dumb is that? So, I
> re-installed the firmware/driver in windows. It said that everything
> went fine. I put it back on my Myth box and it still had the same
> problem.
> Next, I hunted down an old driver/firmware and installed that. Blammo,
> it worked. My videos were 59.94fps! I went back (just for giggles) and
> re-installed (for the 3rd time) the newest firmware/driver and it
> continued to record videos at 59.94fps.
> So, either the new firmware simply won't take on my unit and I'm on
> the old firmware....or putting an old firmware on the box and then
> trying the new firmware again worked...?
> But, there is NO WAY to tell what firmware you have on the box. Dumb dumb dumb.
> I do know that older firmware can be a little problematic. The box can
> freeze up and Linux can even sometimes loose the device...i.e. you
> need to unplug the USB and plug it back in.
> So far, I have not had that problem, so I suspect that the new
> firmware did take."

Loading the hdpvr module logs the firmware version.  Easiest to grab
it from dmesg..

More information about the mythtv-users mailing list