[mythtv-users] 720p HD content from WPVI in Philly periodic a/v sync issues

Bob Sully rcs at malibyte.net
Wed Feb 10 01:55:49 UTC 2010

Taylor Ralph wrote:
> On Wed, Feb 3, 2010 at 5:06 PM, Bob Sully <rcs at malibyte.net> wrote:
>> I know this is resurrecting an old thread (December).
>> However, I ran a search on the archives because I am having a similar
>> problem with ONE QAM HD channel (KTTV, channel 11 (FOX) out of Los
>> Angeles) when recording via my HDHR (from Time-Warner Cable). The same
>> tuner with other QAM HD channels (CBS, ABC, NBC, etc.) makes perfect
>> recordings with no sync issues.
>> With the Fox channel (past two or three recordings of "24") the video
>> and
>> audio are out of sync, with choppy speed changes at the beginning of the
>> recording.  The latter goes away after a few minutes but the audio and
>> video remain out of sync for the whole hour.
>> Interestingly, in two cases, running the recording through ffmpeg (two
>> passes; changed the frame rate to 29.97 from 59.94 (60?) and the format
>> to
>> .avi) and then editing out the commercials with avidemux FIXED the
>> problem.  However, with this past Monday's episode, it only fixed it for
>> the first half of the file.
>> I'm running Jean-Yves Avenard's latest (testing) versions of 0.22-fixes
>> with VDPAU nVidia drivers on Ubuntu 9.10, and have had no other
>> problems.
>> CPU is a 2.4GHZ Q6600; average CPU hit while playing a recording is
>> between 1 and 4%.
>> The previous thread mentioned a patch (which apparently solves this
>> problem) that is slated for inclusion in an upcoming version of -fixes.
>> Anyone know if/when that will be happening?
>> Thanks!  Otherwise, I'm very happy with my setup (outside of
>> occasionally
>> having to reset the sound driver with alsamixer....but that's a
>> pulseaudio/ALSA issue, nothing to do with Myth).
>> Bob
> The patch is now applied to trunk so it will be in the upcoming 0.23
> release. If you like to live on the edge you can run the trunk
> packages but be aware that you will have to restore your database if
> you choose to return to 0.22-fixes.
> Regards.
> --
> Taylor

Taylor - thanks for the info.

Had the same problem with FOX last night on playback of a recording, but
after running the file through ffmpeg x 2 and then avidemux (to excise the
commercials), the finished file is in sync.  As everything else is working
well for the most part, I'll stick with my current setup and wait for 0.23
to be released.   Thanks for your work on the patch!

Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list