[mythtv-users] revo hdmi audio - what am I doing wrong?

John Luber john at luberfamily.net
Tue Feb 2 12:12:02 UTC 2010

Jerry Rubinow wrote:
> On Mon, Feb 1, 2010 at 9:57 PM, Nick Rout <nick.rout at gmail.com 
> <mailto:nick.rout at gmail.com>> wrote:
>     I have a revo 1600. I booted it from a ubuntu netbook remix 9.10 usb
>     flash drive (because its what I had to hand).
>     It came up using the nv driver in 1280x720
>     I unmuted iec958 in alsamixer.
>     I installed mplayer-nogui
>     I ensured that aplay -L had an hdmi listing.
>     I tried mplayer -ao alsa:device=hdmi file.mkv
>     and got no sound. What am I doing wrong?
>     This machine is naturally destined to be a frontend.
> I have a Revo 1600 running mythbuntu 9.10 as a FE, never tried 
> mplayer, but did the alsamixer unmute and set "Audio output device" to 
> ALSA:hdmi in myth and it just worked.  Are you sure you have sound 
> going in over the hdmi connection?  Did you try running a FE on it?
> hth,
> Jerry
> ------------------------------------------------------------------------
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

I have an Acer Revo 1600 as a front end and it works great; low noise, 
low power consumption, reliable, etc.  I initially set it up as Jerry 
suggested and all was well until I tried to play music with it.  No 
matter what I tried I received "Error: Rate doesn't match (requested 
44100Hz, got 48000Hz)" in the logs and no sound.

After a lot of googling and a request to this list Jedi suggested the 

   On my Revo I use an .asoundrc file that seems to have been passed 
around a number of XBMC support forums.

--------------------- .asoundrc ----------------------------------

### .asoundrc for Acer Revo

pcm.dmixer {
   type dmix
   ipc_key 1024
   ipc_key_add_uid false
   ipc_perm 0660
   slave {
      pcm "hw:0,3"
      rate 48000
      channels 2
      format S32_LE
      period_time 0
      period_size 1024
      buffer_time 0
      buffer_size 4096

pcm.!default {
   type plug
   slave.pcm "dmixer"

Placing the above in the mythtv user's home directory and reverting back 
to ALSA:default in the mythtv setup allows sound to work for both TV 
playback and myth music.

Hope it works for you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100202/c1436166/attachment.htm>

More information about the mythtv-users mailing list